summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/redirbot/redirbot-0.0.4.ebuild')
-rw-r--r--net-irc/redirbot/redirbot-0.0.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-irc/redirbot/redirbot-0.0.4.ebuild b/net-irc/redirbot/redirbot-0.0.4.ebuild
new file mode 100644
index 000000000000..18517f42a099
--- /dev/null
+++ b/net-irc/redirbot/redirbot-0.0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/redirbot/redirbot-0.0.4.ebuild,v 1.1 2013/06/25 12:37:27 yac Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+DOCS=( ChangeLog README.rst )
+
+inherit distutils-r1
+
+DESCRIPTION="IRCBot, telling people they should contact you on different nickname"
+HOMEPAGE="https://github.com/yaccz/redirbot"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/twisted-11.1.0
+ dev-python/twisted-words
+"
+RDEPEND="${DEPEND}"