summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/loqui/loqui-0.4.1.ebuild')
-rw-r--r--net-irc/loqui/loqui-0.4.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-irc/loqui/loqui-0.4.1.ebuild b/net-irc/loqui/loqui-0.4.1.ebuild
new file mode 100644
index 000000000000..c8260708ebce
--- /dev/null
+++ b/net-irc/loqui/loqui-0.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/loqui/loqui-0.4.1.ebuild,v 1.1 2005/07/21 23:20:44 swegener Exp $
+
+MY_P="${P/_}"
+
+DESCRIPTION="Loqui is a graphical IRC client for GNOME2 on UNIX like operating system."
+SRC_URI="http://loqui.good-day.net/src/${MY_P}.tar.gz"
+HOMEPAGE="http://loqui.good-day.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.2.1
+ >=x11-libs/gtk+-2.4
+ >=net-libs/gnet-2.0.3"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ econf $(use_enable nls) || die "Configure failed"
+ emake || die "Compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}