summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/snort')
-rw-r--r--net-analyzer/snort/ChangeLog6
-rw-r--r--net-analyzer/snort/snort-2.8.5.1.ebuild4
-rw-r--r--net-analyzer/snort/snort-2.8.5.3.ebuild6
-rw-r--r--net-analyzer/snort/snort-2.8.6.1.ebuild6
-rw-r--r--net-analyzer/snort/snort-2.8.6.ebuild6
5 files changed, 16 insertions, 12 deletions
diff --git a/net-analyzer/snort/ChangeLog b/net-analyzer/snort/ChangeLog
index 1053059ba987..e33447d28091 100644
--- a/net-analyzer/snort/ChangeLog
+++ b/net-analyzer/snort/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/snort
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.180 2011/03/17 10:37:26 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/ChangeLog,v 1.181 2011/04/02 12:52:27 ssuominen Exp $
+
+ 02 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> snort-2.8.5.1.ebuild,
+ snort-2.8.5.3.ebuild, snort-2.8.6.ebuild, snort-2.8.6.1.ebuild:
+ Use net-libs/libpcap instead of virtual/libpcap wrt #358835.
17 Mar 2011; Patrick Lauer <patrick@gentoo.org> snort-2.9.0.4-r1.ebuild:
amd64 stable as I accidentally dropped .3 with stable keyword
diff --git a/net-analyzer/snort/snort-2.8.5.1.ebuild b/net-analyzer/snort/snort-2.8.5.1.ebuild
index 2f641c7a3c1f..3cd08272faad 100644
--- a/net-analyzer/snort/snort-2.8.5.1.ebuild
+++ b/net-analyzer/snort/snort-2.8.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.8.5.1.ebuild,v 1.9 2011/01/13 13:43:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.8.5.1.ebuild,v 1.10 2011/04/02 12:52:27 ssuominen Exp $
inherit eutils autotools multilib
@@ -13,7 +13,7 @@ KEYWORDS="alpha amd64 ppc ppc64 ~sparc ~x86"
IUSE="static dynamicplugin ipv6 gre mpls targetbased decoder-preprocessor-rules ppm timestats perfprofiling linux-smp-stats inline inline-init-failopen prelude threads debug reload reload-error-restart flexresp flexresp2 react aruba mysql odbc postgres selinux"
#flexresp, react, and inline _ONLY_ work with net-libs/libnet-1.0.2a
-DEPEND="virtual/libpcap
+DEPEND="net-libs/libpcap
>=dev-libs/libpcre-6.0
flexresp2? ( dev-libs/libdnet )
flexresp? ( ~net-libs/libnet-1.0.2a )
diff --git a/net-analyzer/snort/snort-2.8.5.3.ebuild b/net-analyzer/snort/snort-2.8.5.3.ebuild
index 94fc6e0c6d4e..2a106693d298 100644
--- a/net-analyzer/snort/snort-2.8.5.3.ebuild
+++ b/net-analyzer/snort/snort-2.8.5.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.8.5.3.ebuild,v 1.4 2010/07/11 12:09:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.8.5.3.ebuild,v 1.5 2011/04/02 12:52:27 ssuominen Exp $
inherit eutils autotools multilib
@@ -14,7 +14,7 @@ KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="static dynamicplugin ipv6 gre mpls targetbased decoder-preprocessor-rules ppm timestats perfprofiling linux-smp-stats inline inline-init-failopen prelude threads debug reload reload-error-restart flexresp flexresp2 react aruba mysql odbc postgres selinux"
#flexresp, react, and inline _ONLY_ work with net-libs/libnet-1.0.2a
-DEPEND="virtual/libpcap
+DEPEND="net-libs/libpcap
>=dev-libs/libpcre-6.0
flexresp2? ( dev-libs/libdnet )
flexresp? ( ~net-libs/libnet-1.0.2a )
diff --git a/net-analyzer/snort/snort-2.8.6.1.ebuild b/net-analyzer/snort/snort-2.8.6.1.ebuild
index 297350952c0b..3d9c61b74b7b 100644
--- a/net-analyzer/snort/snort-2.8.6.1.ebuild
+++ b/net-analyzer/snort/snort-2.8.6.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.8.6.1.ebuild,v 1.1 2010/08/13 11:12:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.8.6.1.ebuild,v 1.2 2011/04/02 12:52:27 ssuominen Exp $
EAPI="2"
inherit eutils autotools multilib
@@ -17,7 +17,7 @@ threads debug reload reload-error-restart flexresp flexresp2 react aruba mysql
odbc postgres selinux zlib"
#flexresp, react, and inline _ONLY_ work with net-libs/libnet-1.0.2a
-DEPEND="virtual/libpcap
+DEPEND="net-libs/libpcap
>=dev-libs/libpcre-6.0
flexresp2? ( dev-libs/libdnet )
flexresp? ( ~net-libs/libnet-1.0.2a )
diff --git a/net-analyzer/snort/snort-2.8.6.ebuild b/net-analyzer/snort/snort-2.8.6.ebuild
index 992b1b49adb5..7d78d0087760 100644
--- a/net-analyzer/snort/snort-2.8.6.ebuild
+++ b/net-analyzer/snort/snort-2.8.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.8.6.ebuild,v 1.3 2010/07/19 21:39:10 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.8.6.ebuild,v 1.4 2011/04/02 12:52:27 ssuominen Exp $
inherit eutils autotools multilib
@@ -16,7 +16,7 @@ threads debug reload reload-error-restart flexresp flexresp2 react aruba mysql
odbc postgres selinux zlib"
#flexresp, react, and inline _ONLY_ work with net-libs/libnet-1.0.2a
-DEPEND="virtual/libpcap
+DEPEND="net-libs/libpcap
>=dev-libs/libpcre-6.0
flexresp2? ( dev-libs/libdnet )
flexresp? ( ~net-libs/libnet-1.0.2a )