summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/acid')
-rw-r--r--net-analyzer/acid/ChangeLog5
-rw-r--r--net-analyzer/acid/acid-0.9.6_beta23.ebuild23
2 files changed, 20 insertions, 8 deletions
diff --git a/net-analyzer/acid/ChangeLog b/net-analyzer/acid/ChangeLog
index 2730692162f1..c3b8b1c63e56 100644
--- a/net-analyzer/acid/ChangeLog
+++ b/net-analyzer/acid/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/acid
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/ChangeLog,v 1.4 2004/10/11 23:10:52 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/ChangeLog,v 1.5 2004/10/14 11:31:09 eldad Exp $
+
+ 14 Oct 2004; Eldad Zack <eldad@gentoo.org> acid-0.9.6_beta23.ebuild:
+ Fixed pkg_setup.
12 Oct 2004; Eldad Zack <eldad@gentoo.org> acid-0.9.6_beta23.ebuild:
Added deps media-libs/gd and dev-php/mod_php. Added a check to see if mod_php
diff --git a/net-analyzer/acid/acid-0.9.6_beta23.ebuild b/net-analyzer/acid/acid-0.9.6_beta23.ebuild
index 0512dde4808f..52564b02f00c 100644
--- a/net-analyzer/acid/acid-0.9.6_beta23.ebuild
+++ b/net-analyzer/acid/acid-0.9.6_beta23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/acid-0.9.6_beta23.ebuild,v 1.5 2004/10/11 23:10:52 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/acid-0.9.6_beta23.ebuild,v 1.6 2004/10/14 11:31:09 eldad Exp $
inherit webapp
@@ -24,15 +24,24 @@ DEPEND="apache2? ( >=net-www/apache-2 )
dev-php/mod_php
net-analyzer/snort"
-pkg_setup() {
- # Check if mod_php was emerged with GD
- my_modphp=$(best_version dev-php/mod_php)
+check_useflag() {
+ local my_pkg=$(best_version ${1})
+ local my_flag=${2}
- if [[ ! $(grep -wo gd /var/db/pkg/${my_modphp}/USE) ]];
+ if [[ $(grep -wo ${my_flag} /var/db/pkg/${my_pkg}/USE) ]]
then
- eerror "${my_modphp} was compiled without gd support. Please reemerge it with USE=gd."
- die "pkg_setup failed"
+ return 0
fi
+
+ eerror "${my_pkg} was compiled without ${my_flag}. Please re-emerge it with USE=${my_flag}"
+ die "check_useflag failed"
+
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ check_useflag dev-php/mod_php gd
}
src_compile () {