summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild')
-rw-r--r--media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild b/media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild
new file mode 100644
index 000000000000..4e3cc92a2762
--- /dev/null
+++ b/media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbisgain/vorbisgain-0.37-r1.ebuild,v 1.1 2008/03/22 07:41:48 drac Exp $
+
+inherit eutils
+
+DESCRIPTION="Calculator of perceived sound level for Ogg Vorbis files"
+HOMEPAGE="http://sjeng.org/vorbisgain.html"
+SRC_URI="http://sjeng.org/ftp/vorbis/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libvorbis-1
+ media-libs/libogg"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fix-errno-and-warnings.patch # bug 200931
+}
+
+src_compile() {
+ econf --enable-recursive
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc NEWS README *.txt
+}