summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/sonata')
-rw-r--r--media-sound/sonata/ChangeLog9
-rw-r--r--media-sound/sonata/files/sonata-1.6.2-keep_icons_constant.patch16
-rw-r--r--media-sound/sonata/sonata-1.6.2-r1.ebuild37
3 files changed, 61 insertions, 1 deletions
diff --git a/media-sound/sonata/ChangeLog b/media-sound/sonata/ChangeLog
index a0a07f8fa71b..9123ee0dba77 100644
--- a/media-sound/sonata/ChangeLog
+++ b/media-sound/sonata/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/sonata
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sonata/ChangeLog,v 1.42 2009/05/22 03:06:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sonata/ChangeLog,v 1.43 2009/05/25 12:26:32 ssuominen Exp $
+
+*sonata-1.6.2-r1 (25 May 2009)
+
+ 25 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +sonata-1.6.2-r1.ebuild, +files/sonata-1.6.2-keep_icons_constant.patch:
+ Keep icons constant when adding a stream to a playlist. Patch from
+ upstream wrt #270564, thanks to Marc Arens for reporting.
22 May 2009; Samuli Suominen <ssuominen@gentoo.org> -sonata-1.6.ebuild,
sonata-1.6.2.ebuild:
diff --git a/media-sound/sonata/files/sonata-1.6.2-keep_icons_constant.patch b/media-sound/sonata/files/sonata-1.6.2-keep_icons_constant.patch
new file mode 100644
index 000000000000..95b539340ebb
--- /dev/null
+++ b/media-sound/sonata/files/sonata-1.6.2-keep_icons_constant.patch
@@ -0,0 +1,16 @@
+Fix from upstream. Keep icons constant when adding a stream to a playlist.
+http://bugs.gentoo.org/show_bug.cgi?id=270564
+http://developer.berlios.de/bugs/?func=detailbug&bug_id=15722&group_id=7323
+
+diff -ur sonata-1.6.2.orig/sonata/artwork.py sonata-1.6.2/sonata/artwork.py
+--- sonata-1.6.2.orig/sonata/artwork.py 2009-04-02 06:57:29.000000000 +0300
++++ sonata-1.6.2/sonata/artwork.py 2009-05-25 14:14:48.000000000 +0300
+@@ -228,6 +228,8 @@
+ # Search through the rows in the library to see
+ # if we match the currently playing song:
+ play_artist, play_album = library_get_data(cache_key, 'artist', 'album')
++ if play_artist is None and play_album is None:
++ return
+ for row in self.lib_model:
+ artist, album, path = library_get_data(row[1], 'artist', 'album', 'path')
+ if unicode(play_artist).lower() == unicode(artist).lower() \
diff --git a/media-sound/sonata/sonata-1.6.2-r1.ebuild b/media-sound/sonata/sonata-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..3ac57ae55527
--- /dev/null
+++ b/media-sound/sonata/sonata-1.6.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sonata/sonata-1.6.2-r1.ebuild,v 1.1 2009/05/25 12:26:32 ssuominen Exp $
+
+EAPI=2
+inherit distutils eutils
+
+DESCRIPTION="an elegant GTK+ music client for the Music Player Daemon (MPD)."
+HOMEPAGE="http://sonata.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus lyrics taglib +trayicon"
+
+RDEPEND=">=virtual/python-2.5
+ >=dev-python/pygtk-2.12
+ >=x11-libs/gtk+-2:2[jpeg]
+ >=dev-python/python-mpd-0.2.1
+ dbus? ( dev-python/dbus-python )
+ lyrics? ( dev-python/zsi )
+ taglib? ( >=dev-python/tagpy-0.93 )
+ trayicon? ( dev-python/egg-python )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="CHANGELOG README TODO TRANSLATORS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-keep_icons_constant.patch
+}
+
+src_install() {
+ distutils_src_install
+ rm -rf "${D}"/usr/share/sonata
+}