summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gst-plugins-base/gst-plugins-base-0.10.2.ebuild')
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.2.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.2.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.2.ebuild
deleted file mode 100644
index 02c7e9f99823..000000000000
--- a/media-libs/gst-plugins-base/gst-plugins-base-0.10.2.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-0.10.2.ebuild,v 1.2 2006/01/22 06:55:30 cardoe Exp $
-
-# order is important, gnome2 after gst-plugins
-inherit gst-plugins-base gst-plugins10 gnome2 eutils flag-o-matic libtool
-
-DESCRIPTION="Basepack of plugins for gstreamer"
-HOMEPAGE="http://gstreamer.net/"
-SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND=">=dev-libs/glib-2.6
- >=media-libs/gstreamer-0.10.2
- >=dev-libs/liboil-0.3.2
- || ( ( x11-libs/libXext
- x11-libs/libSM )
- virtual/x11 )"
-
-DEPEND="${RDEPEND}
- >=sys-devel/gettext-0.11.5
- >=dev-util/pkgconfig-0.9
- || ( ( x11-proto/xproto
- x11-proto/videoproto
- x11-proto/xextproto )
- virtual/x11 )"
-
-
-# we need x for the x overlay to get linked
-GST_PLUGINS_BUILD="x xshm"
-
-# overrides the eclass
-src_unpack() {
-
- unpack ${A}
-}
-
-src_compile() {
-
- elibtoolize
-
- # gst doesnt handle optimisations well
- strip-flags
- replace-flags "-O3" "-O2"
- filter-flags "-fprefetch-loop-arrays" # see bug 22249
- if use alpha || use amd64 || use ia64 || use hppa; then
- append-flags -fPIC
- fi
-
- gst-plugins-base_src_configure
-
- emake || die
-
-}
-
-# override eclass
-src_install() {
-
- gnome2_src_install
-
-}
-
-DOCS="AUTHORS INSTALL README RELEASE TODO"
-
-pkg_postinst () {
-
- gnome2_pkg_postinst
-
- echo ""
- einfo "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
- einfo "applications now should provide the basic plugins needed."
- echo ""
- einfo "The new seperate plugins are all named 'gst-plugins-<plugin>'."
- einfo "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
- einfo "In most cases it shouldn't be needed though to emerge extra plugins."
-
-}
-
-pkg_postrm() {
-
- gnome2_pkg_postrm
-
-}