summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kanyremote/kanyremote-5.11.ebuild')
-rw-r--r--kde-misc/kanyremote/kanyremote-5.11.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-misc/kanyremote/kanyremote-5.11.ebuild b/kde-misc/kanyremote/kanyremote-5.11.ebuild
new file mode 100644
index 000000000000..d86ed30abbc4
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-5.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.11.ebuild,v 1.1 2010/01/23 13:43:11 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+DEPEND=">=net-misc/anyremote-4.4[bluetooth?]
+ dev-python/PyQt4[X]
+ kde-base/pykde4
+ bluetooth? ( dev-python/pybluez )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # workaround to bluetooth check when bluetooth use flag is disabled
+ ! use bluetooth && epatch "${FILESDIR}/disable_bluetooth.patch"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}