summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kstartperf/kstartperf-4.2.4.ebuild')
-rw-r--r--kde-base/kstartperf/kstartperf-4.2.4.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/kde-base/kstartperf/kstartperf-4.2.4.ebuild b/kde-base/kstartperf/kstartperf-4.2.4.ebuild
new file mode 100644
index 000000000000..f8487529dca8
--- /dev/null
+++ b/kde-base/kstartperf/kstartperf-4.2.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstartperf/kstartperf-4.2.4.ebuild,v 1.1 2009/06/04 13:20:42 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Messures starting performance of applications"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+src_prepare() {
+ # Disable hardcoded kdepimlibs check - only 4.2 branch is affected
+ sed -i -e 's/find_package(KdepimLibs REQUIRED)/macro_optional_find_package(KdepimLibs)/' \
+ CMakeLists.txt || die "failed to disable kdepimlibs hardcoded check"
+
+ kde4-meta_src_prepare
+}