summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-libs/ammonite')
-rw-r--r--gnome-libs/ammonite/ammonite-1.0.2.ebuild54
1 files changed, 27 insertions, 27 deletions
diff --git a/gnome-libs/ammonite/ammonite-1.0.2.ebuild b/gnome-libs/ammonite/ammonite-1.0.2.ebuild
index 13b07fbfc29c..934f073435da 100644
--- a/gnome-libs/ammonite/ammonite-1.0.2.ebuild
+++ b/gnome-libs/ammonite/ammonite-1.0.2.ebuild
@@ -1,48 +1,48 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-libs/ammonite/ammonite-1.0.2.ebuild,v 1.6 2001/08/23 10:20:31 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-libs/ammonite/ammonite-1.0.2.ebuild,v 1.7 2001/08/31 23:32:48 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="ammonite"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
-
HOMEPAGE="http://www.gnome.org/"
-DEPEND="nls? ( sys-devel/gettext )
- >=gnome-base/gnome-libs-1.2.12
- >=gnome-base/gconf-0.50
- >=dev-libs/openssl-0.9.6
- >=dev-util/xml-i18n-tools-0.8.4"
-
RDEPEND=">=gnome-base/gnome-libs-1.2.12
- >=gnome-base/gconf-0.50
- >=dev-libs/openssl-0.9.6"
+ >=gnome-base/gconf-0.50
+ >=dev-libs/openssl-0.9.6"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/xml-i18n-tools-0.8.4"
src_unpack() {
- unpack ${A}
- cd ${S}
- patch -p1 < ${FILESDIR}/${PN}-1.0.0-gentoo.diff
+ unpack ${A}
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PN}-1.0.0-gentoo.diff || die
}
src_compile() {
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf}
- try pmake
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome \
+ --mandir=/opt/gnome/man ${myconf} || die
+
+ emake || die
}
src_install() {
- try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
- dodoc ABOUT-NLS AUTHORS COPYING* HACKING README NEWS
- dodoc TODO doc/*.txt
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS COPYING* HACKING README NEWS
+ dodoc TODO doc/*.txt
}
-
-
-
-