summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/gwp/gwp-0.4.0-r2.ebuild')
-rw-r--r--games-strategy/gwp/gwp-0.4.0-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-strategy/gwp/gwp-0.4.0-r2.ebuild b/games-strategy/gwp/gwp-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..7c1fb8193512
--- /dev/null
+++ b/games-strategy/gwp/gwp-0.4.0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/gwp/gwp-0.4.0-r2.ebuild,v 1.1 2007/07/02 01:24:59 nyhm Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME client for the classic PBEM strategy game VGA Planets 3"
+HOMEPAGE="http://gwp.lunix.com.ar/"
+SRC_URI="http://gwp.lunix.com.ar/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls opengl python"
+
+RDEPEND="=x11-libs/gtk+-2*
+ =gnome-base/libgnomeui-2*
+ =gnome-base/libglade-2*
+ app-text/scrollkeeper
+ dev-libs/libpcre
+ nls? ( virtual/libintl )
+ opengl? ( =x11-libs/gtkglext-1* )
+ python? ( =dev-python/pygtk-2* )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-exec-stack.patch
+ sed -i \
+ -e '/ -O1/d' \
+ -e '/ -g$/d' \
+ src/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ gnome2_src_compile \
+ $(use_enable nls) \
+ $(use_enable opengl gtkglext) \
+ $(use_enable python)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog CHANGES README TODO" \
+ gnome2_src_install
+ rm -rf "${D}"/usr/share/doc/gwp
+}