summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ngstar/ChangeLog8
-rw-r--r--games-puzzle/ngstar/files/ngstar-2.1.8-gcc47.patch11
-rw-r--r--games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild5
3 files changed, 20 insertions, 4 deletions
diff --git a/games-puzzle/ngstar/ChangeLog b/games-puzzle/ngstar/ChangeLog
index fc024048d662..ee13bd17b0ba 100644
--- a/games-puzzle/ngstar/ChangeLog
+++ b/games-puzzle/ngstar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/ngstar
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ChangeLog,v 1.9 2011/06/19 21:53:04 mr_bones_ Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ChangeLog,v 1.10 2012/07/21 20:33:46 tupone Exp $
+
+ 21 Jul 2012; Tupone Alfredo <tupone@gentoo.org> ngstar-2.1.8-r2.ebuild,
+ +files/ngstar-2.1.8-gcc47.patch:
+ Fix build with gcc-4.7 Bug #424735 by Diego Elio Pettenò
19 Jun 2011; Michael Sterrett <mr_bones_@gentoo.org> ngstar-2.1.8-r2.ebuild:
upstream went away so update to other values for homepage and src_uri (bug
diff --git a/games-puzzle/ngstar/files/ngstar-2.1.8-gcc47.patch b/games-puzzle/ngstar/files/ngstar-2.1.8-gcc47.patch
new file mode 100644
index 000000000000..2ddf0f53793d
--- /dev/null
+++ b/games-puzzle/ngstar/files/ngstar-2.1.8-gcc47.patch
@@ -0,0 +1,11 @@
+--- src/Ncurses_UI.cc.old 2012-07-21 22:25:16.421521521 +0200
++++ src/Ncurses_UI.cc 2012-07-21 22:26:01.008390914 +0200
+@@ -23,6 +23,8 @@
+ /* includes */
+ #include "Ncurses_UI.hh"
+
++#include <unistd.h>
++
+ using namespace ngstar2;
+
+ Ncurses_UI::Ncurses_UI( NGStar2 *engine, Configuration* config, Scores *scores )
diff --git a/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild b/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
index 7149b69de39c..4c4db3b6b78d 100644
--- a/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
+++ b/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild,v 1.8 2011/06/19 21:53:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild,v 1.9 2012/07/21 20:33:46 tupone Exp $
EAPI=2
inherit eutils games
@@ -21,6 +21,7 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-gentoo-path.patch \
"${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
"${FILESDIR}"/${P}-ldflags.patch
sed -i \
-e "s:@GENTOO_DATA@:${GAMES_DATADIR}:" \