summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gens/gens-2.12b.ebuild')
-rw-r--r--games-emulation/gens/gens-2.12b.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-emulation/gens/gens-2.12b.ebuild b/games-emulation/gens/gens-2.12b.ebuild
new file mode 100644
index 000000000000..de183c7d433c
--- /dev/null
+++ b/games-emulation/gens/gens-2.12b.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.12b.ebuild,v 1.1 2005/01/02 02:41:59 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="A Sega Genesis/CD/32X emulator"
+HOMEPAGE="http://gens.consolemul.com/"
+SRC_URI="mirror://sourceforge/gens/gens-rc3.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="virtual/libc
+ >=media-libs/libsdl-1.2
+ >=x11-libs/gtk+-2.0*"
+DEPEND="${RDEPEND}
+ >=dev-lang/nasm-0.98
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/GensForLinux"
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS BUGS README
+ prepgamesdirs
+}