summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/apitrace/files/apitrace-2.0-glxtrace-only.patch')
-rw-r--r--dev-util/apitrace/files/apitrace-2.0-glxtrace-only.patch78
1 files changed, 78 insertions, 0 deletions
diff --git a/dev-util/apitrace/files/apitrace-2.0-glxtrace-only.patch b/dev-util/apitrace/files/apitrace-2.0-glxtrace-only.patch
new file mode 100644
index 000000000000..d9499cf5fba1
--- /dev/null
+++ b/dev-util/apitrace/files/apitrace-2.0-glxtrace-only.patch
@@ -0,0 +1,78 @@
+--- apitrace-apitrace-e2c4320/CMakeLists.txt.orig
++++ apitrace-apitrace-e2c4320/CMakeLists.txt
+@@ -17,6 +17,7 @@
+ # prescribed in http://www.gentoo.org/proj/en/qa/automagic.xml
+ set (ENABLE_GUI "AUTO" CACHE STRING "Enable Qt GUI.")
+
++option (BUILD_LIB_ONLY "Build the glxtrace library only" OFF)
+
+ ##############################################################################
+ # Find dependencies
+@@ -137,6 +138,8 @@
+ # - on unices to prevent symbol collisions when tracing applications that link
+ # against other versions of these libraries
+
++if (NOT BUILD_LIB_ONLY)
++
+ find_package (ZLIB REQUIRED)
+ include_directories (${ZLIB_INCLUDE_DIRS})
+ link_libraries (${ZLIB_LIBRARIES})
+@@ -166,6 +169,8 @@
+ set (QJSON_FOUND TRUE)
+ endif ()
+
++endif (NOT BUILD_LIB_ONLY)
++
+ # For glext headers
+ include_directories (${CMAKE_CURRENT_SOURCE_DIR}/thirdparty)
+
+@@ -184,6 +189,8 @@
+ DEPENDS glproc.py dispatch.py specs/wglapi.py specs/glxapi.py specs/cglapi.py specs/glapi.py specs/gltypes.py specs/stdapi.py
+ )
+
++if (NOT BUILD_LIB_ONLY)
++
+ if (WIN32)
+ set (os os_win32.cpp)
+ set (glws glws_wgl.cpp)
+@@ -218,6 +225,7 @@
+ add_executable (tracedump tracedump.cpp)
+ install (TARGETS tracedump RUNTIME DESTINATION bin)
+
++endif (NOT BUILD_LIB_ONLY)
+
+ ##############################################################################
+ # API tracers
+@@ -374,6 +382,8 @@
+ ##############################################################################
+ # API retracers
+
++if (NOT BUILD_LIB_ONLY)
++
+ add_custom_command (
+ OUTPUT glretrace_gl.cpp
+ COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/glretrace.py > ${CMAKE_CURRENT_BINARY_DIR}/glretrace_gl.cpp
+@@ -386,11 +396,15 @@
+ DEPENDS glstate.py specs/glparams.py specs/gltypes.py specs/stdapi.py
+ )
+
++endif (NOT BUILD_LIB_ONLY)
++
+ include_directories (
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${OPENGL_INCLUDE_PATH}
+ )
+
++if (NOT BUILD_LIB_ONLY)
++
+ add_executable (glretrace
+ glretrace_gl.cpp
+ glretrace_cgl.cpp
+@@ -438,6 +452,7 @@
+ add_subdirectory(gui)
+ endif ()
+
++endif (NOT BUILD_LIB_ONLY)
+
+ ##############################################################################
+ # Packaging