summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/lgrind/lgrind-3.67-r1.ebuild')
-rw-r--r--dev-tex/lgrind/lgrind-3.67-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-tex/lgrind/lgrind-3.67-r1.ebuild b/dev-tex/lgrind/lgrind-3.67-r1.ebuild
new file mode 100644
index 000000000000..7a6781fcd44f
--- /dev/null
+++ b/dev-tex/lgrind/lgrind-3.67-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/lgrind/lgrind-3.67-r1.ebuild,v 1.1 2004/02/20 18:35:47 usata Exp $
+
+inherit latex-package
+
+DESCRIPTION="A source pretty printer for LaTeX - styles to stylise your source and code examples."
+SRC_URI="mirror://gentoo/${PN}.tar.gz"
+LICENSE="as-is"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+
+ cd ${S}/source
+ emake || die "Error compiling lgrind executable"
+ latex-package_src_compile
+
+}
+
+src_install() {
+
+ # binary first
+ dobin source/lgrind
+
+ # then the texmf stuff
+ latex-package_src_install
+ insinto /usr/share/texmf/tex/latex/${PN}
+ doins lgrindef
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/99lgrind || die
+
+ # and finally, the documentation
+ dodoc FAQ README
+ docinto examples/
+ dodoc example/*
+ cd ${S}/source
+ doman lgrind.1 lgrindef.5
+
+}