summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/fast_xs')
-rw-r--r--dev-ruby/fast_xs/ChangeLog7
-rw-r--r--dev-ruby/fast_xs/fast_xs-0.8.0-r2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/fast_xs/ChangeLog b/dev-ruby/fast_xs/ChangeLog
index dadbd113cbb3..ee7839dbbc3c 100644
--- a/dev-ruby/fast_xs/ChangeLog
+++ b/dev-ruby/fast_xs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fast_xs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_xs/ChangeLog,v 1.28 2014/04/05 14:20:03 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_xs/ChangeLog,v 1.29 2014/04/20 06:24:29 graaff Exp $
+
+*fast_xs-0.8.0-r2 (20 Apr 2014)
+
+ 20 Apr 2014; Hans de Graaff <graaff@gentoo.org> +fast_xs-0.8.0-r2.ebuild:
+ Add ruby21. Avoid hoe for document building.
05 Apr 2014; Manuel Rüger <mrueg@gentoo.org> fast_xs-0.8.0-r1.ebuild,
fast_xs-0.8.0.ebuild:
diff --git a/dev-ruby/fast_xs/fast_xs-0.8.0-r2.ebuild b/dev-ruby/fast_xs/fast_xs-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..b721ac0b6950
--- /dev/null
+++ b/dev-ruby/fast_xs/fast_xs-0.8.0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_xs/fast_xs-0.8.0-r2.ebuild,v 1.1 2014/04/20 06:24:29 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="fast_xs text escaping library ruby bindings."
+HOMEPAGE="http://fast-xs.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/hoe-2.3.2
+ dev-ruby/rack
+)"
+
+RUBY_PATCHES=( "${P}+ruby-1.9.patch" )
+
+each_ruby_configure() {
+ ${RUBY} -Cext/fast_xs extconf.rb || die "extconf.rb failed"
+ ${RUBY} -Cext/fast_xs_extra extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext/fast_xs CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/fast_xs/fast_xs$(get_modname) lib/ || die
+ emake -Cext/fast_xs_extra CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/fast_xs_extra/fast_xs_extra$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ # the Rakefile tries to run all the tests in a single process, but
+ # this breaks the monkey-patchers, we're forced to run them one by
+ # one.
+ for tu in test/test_*.rb; do
+ ${RUBY} -Ilib $tu || die "test $tu failed"
+ done
+}