summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild')
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild
index 5b114d95baa9..31646d0bad1c 100644
--- a/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild,v 1.1 2014/12/25 12:37:51 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiproxy2/wsgiproxy2-0.4.2.ebuild,v 1.2 2014/12/28 00:57:27 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -25,10 +25,11 @@ RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND}
- dev-python/webtest[${PYTHON_USEDEP}]
+ >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
dev-python/socketpool[${PYTHON_USEDEP}]
dev-python/restkit[$(python_gen_usedep python2_7)] )"
# Tests needing restkit are skipped under py3
+# Testing also revealed the suite needs latest webtest
S="${WORKDIR}/${MY_PN}-${PV}"
@@ -39,7 +40,6 @@ python_compile_all() {
fi
}
-# this was always possible
python_test() {
nosetests || die "Tests fail with ${EPYTHON}"
}