summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-gnupg/python-gnupg-0.3.1-r1.ebuild')
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.3.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-gnupg/python-gnupg-0.3.1-r1.ebuild b/dev-python/python-gnupg/python-gnupg-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..ef9f4b8032ad
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.3.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gnupg/python-gnupg-0.3.1-r1.ebuild,v 1.1 2013/01/08 19:00:42 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for GNU Privacy Guard"
+HOMEPAGE="http://code.google.com/p/python-gnupg/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-crypt/gnupg"
+
+# Tests hang, bug #449638.
+RESTRICT=test
+
+python_test() {
+ "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
+}