summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django/django-1.0.4.ebuild')
-rw-r--r--dev-python/django/django-1.0.4.ebuild61
1 files changed, 33 insertions, 28 deletions
diff --git a/dev-python/django/django-1.0.4.ebuild b/dev-python/django/django-1.0.4.ebuild
index 9c0e31a7d677..60f16adfb477 100644
--- a/dev-python/django/django-1.0.4.ebuild
+++ b/dev-python/django/django-1.0.4.ebuild
@@ -1,21 +1,22 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.0.4.ebuild,v 1.1 2009/10/09 23:05:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.0.4.ebuild,v 1.2 2010/05/26 17:58:12 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
-inherit bash-completion distutils multilib versionator webapp
+inherit bash-completion distutils webapp
-MY_P="${P/#d/D}"
-WEBAPP_MANUAL_SLOT="yes"
+MY_P="Django-${PV}"
DESCRIPTION="High-level python web framework"
-HOMEPAGE="http://www.djangoproject.com/"
+HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
SRC_URI="http://media.djangoproject.com/releases/${PV}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="doc examples mysql postgres sqlite test"
RDEPEND="dev-python/imaging
@@ -31,58 +32,62 @@ DEPEND="${RDEPEND}
>=dev-lang/python-2.5[sqlite]
( dev-python/pysqlite:2 <dev-lang/python-2.5 )
) )"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
-PYTHON_MODNAME="django"
-
DOCS="docs/* AUTHORS"
+WEBAPP_MANUAL_SLOT="yes"
+
+pkg_setup() {
+ python_pkg_setup
+ webapp_pkg_setup
+}
src_compile() {
distutils_src_compile
- if use doc ; then
+ if use doc; then
pushd docs > /dev/null
- emake html || die "Generation of HTML documentation failed"
+ einfo "Generation of documentation"
+ emake html || die "Generation of documentation failed"
popd > /dev/null
fi
}
src_test() {
- einfo "Running tests."
- cat >> tests/settings.py << __EOF__
+ testing() {
+ cat >> tests/settings.py << __EOF__
DATABASE_ENGINE='sqlite3'
DATABASE_NAME='test.db'
ROOT_URLCONF='tests/urls.py'
SITE_ID=1
__EOF__
- PYTHONPATH="." ${python} tests/runtests.py --settings=settings -v1 || die "tests failed"
+ # Tests have non-standard assumptions about PYTHONPATH and
+ # don't work with usual "build-${PYTHON_ABI}/lib".
+ PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=settings -v1
+ }
+ python_execute_function testing
}
src_install() {
- distutils_python_version
- site_pkgs="$(python_get_sitedir)"
- export PYTHONPATH="${PYTHONPATH}:${D}/${site_pkgs}"
- dodir ${site_pkgs}
-
distutils_src_install
dobashcompletion extras/django_bash_completion
- if use examples ; then
+ if use examples; then
insinto /usr/share/doc/${PF}
doins -r examples
fi
- if use doc ; then
- mv docs/_build/html/{_,.}sources
- dohtml txt -r docs/_build/html/*
+ if use doc; then
+ rm -fr docs/_build/html/_sources
+ dohtml -A txt -r docs/_build/html/*
fi
- insinto "${MY_HTDOCSDIR}"
- doins -r "${D}/${site_pkgs}"/django/contrib/admin/media/*
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r django/contrib/admin/media/* || die "doins failed"
- #webapp_postinst_txt en "${WORKDIR}"/postinstall-en.txt
webapp_src_install
}
@@ -93,6 +98,7 @@ pkg_preinst() {
pkg_postinst() {
bash-completion_pkg_postinst
distutils_pkg_postinst
+
einfo "Now, Django has the best of both worlds with Gentoo,"
einfo "ease of deployment for production and development."
echo
@@ -101,7 +107,6 @@ pkg_postinst() {
elog "as well as the traditional location in python's"
elog "site-packages dir for easy development"
echo
- echo
ewarn "If you build Django ${PV} without USE=\"vhosts\""
ewarn "webapp-config will automatically install the"
ewarn "admin media into the localhost webroot."