summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/arrayterator/arrayterator-1.0.ebuild')
-rw-r--r--dev-python/arrayterator/arrayterator-1.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/arrayterator/arrayterator-1.0.ebuild b/dev-python/arrayterator/arrayterator-1.0.ebuild
new file mode 100644
index 000000000000..62c0b9c1e188
--- /dev/null
+++ b/dev-python/arrayterator/arrayterator-1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/arrayterator/arrayterator-1.0.ebuild,v 1.1 2009/02/03 21:22:50 patrick Exp $
+
+inherit distutils
+
+DESCRIPTION="This class creates a buffered iterator for reading big arrays in
+small contiguous blocks."
+HOMEPAGE="http://pypi.python.org/pypi/arrayterator"
+
+SRC_URI="http://cheeseshop.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+#IUSE="server"
+IUSE=""
+RDEPEND="virtual/python
+ >=dev-python/numpy-1.0_rc1"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6_rc3"
+
+