summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/uthash/ChangeLog8
-rw-r--r--dev-libs/uthash/uthash-1.9.7.ebuild32
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-libs/uthash/ChangeLog b/dev-libs/uthash/ChangeLog
index b6b57da46f28..4dcef9c4f898 100644
--- a/dev-libs/uthash/ChangeLog
+++ b/dev-libs/uthash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/uthash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/ChangeLog,v 1.3 2012/05/05 08:33:03 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/ChangeLog,v 1.4 2012/10/16 20:58:55 hwoarang Exp $
+
+*uthash-1.9.7 (16 Oct 2012)
+
+ 16 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +uthash-1.9.7.ebuild:
+ Version bump. Bug #438514
*uthash-1.9.6 (05 May 2012)
@@ -17,4 +22,3 @@
14 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +uthash-1.9.4.ebuild,
+metadata.xml:
Initial commit. Thanks to Johan Bergström <bugs@bergstroem.nu>. Bug #205911
-
diff --git a/dev-libs/uthash/uthash-1.9.7.ebuild b/dev-libs/uthash/uthash-1.9.7.ebuild
new file mode 100644
index 000000000000..ca3415689090
--- /dev/null
+++ b/dev-libs/uthash/uthash-1.9.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/uthash-1.9.7.ebuild,v 1.1 2012/10/16 20:58:55 hwoarang Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy-to-use hash implementation for C programmers"
+HOMEPAGE="http://uthash.sourceforge.net"
+SRC_URI="mirror://sourceforge/uthash/${P}.tar.bz2"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-lang/perl )"
+RDEPEND=""
+
+src_test() {
+ cd tests
+ sed -i "/CFLAGS/s/-O3/${CFLAGS}/" Makefile || die "sed cflags failed"
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ insinto /usr/include
+ doins src/*.h || die "doins failed"
+
+ dodoc doc/txt/{ChangeLog,userguide,ut*}.txt
+}