summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xmlrpc-c/xmlrpc-c-1.06.09.ebuild')
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.06.09.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.06.09.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.06.09.ebuild
new file mode 100644
index 000000000000..d4031e658396
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.06.09.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.06.09.ebuild,v 1.1 2007/02/15 10:25:22 hollow Exp $
+
+inherit eutils
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+SRC_URI="mirror://sourceforge/xmlrpc-c/${P}.tgz"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="curl libwww threads"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/libc
+ dev-libs/libxml2
+ libwww? ( net-libs/libwww )
+ curl? ( net-misc/curl )"
+
+pkg_setup() {
+ # paralell make doesn't work
+ MAKEOPTS="-j1"
+
+ if ! use curl && ! use libwww; then
+ ewarn "Neither CURL nor libwww support was selected"
+ ewarn "No client library will be be built"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.05-pic.patch
+ epatch "${FILESDIR}"/${PN}-1.06.02-threadupdatestatus.patch
+ epatch "${FILESDIR}"/${PN}-1.06.02-strsol.patch
+}
+
+src_compile() {
+ econf --disable-wininet-client --enable-libxml2-backend \
+ $(use_enable threads abyss-threads) \
+ $(use_enable curl curl-client) \
+ $(use_enable libwww libwww-client) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}