summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/uclibc/uclibc-0.9.20.ebuild')
-rw-r--r--dev-libs/uclibc/uclibc-0.9.20.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/uclibc/uclibc-0.9.20.ebuild b/dev-libs/uclibc/uclibc-0.9.20.ebuild
new file mode 100644
index 000000000000..d569ee3d6bbc
--- /dev/null
+++ b/dev-libs/uclibc/uclibc-0.9.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uclibc/uclibc-0.9.20.ebuild,v 1.1 2003/07/07 20:27:07 vapier Exp $
+
+inherit eutils
+
+MY_P="${P/ucl/uCl}"
+DESCRIPTION="C library for developing embedded Linux systems"
+HOMEPAGE="http://www.uclibc.org/"
+SRC_URI="http://www.kernel.org/pub/linux/libs/uclibc/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="sys-devel/gcc"
+PROVIDE="virtual/glibc"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ make defconfig || die "could not config"
+ for def in UCLIBC_HAS_LOCALE DODEBUG DOASSERTS SUPPORT_LD_DEBUG SUPPORT_LD_DEBUG_EARLY ; do
+ sed -i "s:${def}=y:# ${def} is not set:" .config
+ done
+ cp .config myconfig
+
+ for f in `grep -Rl 'subst -g' *` ; do
+ sed -i -e "/subst -g/s:-g:\\' -g \\':" ${f}
+ done
+
+ emake clean || die "could not clean"
+}
+
+src_compile() {
+ mv myconfig .config
+ make || die "could not make"
+}
+
+src_install() {
+ make PREFIX=${D} install || die "install failed"
+}