summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild')
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild b/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild
new file mode 100644
index 000000000000..12277d02b216
--- /dev/null
+++ b/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.2_alpha4-r1.ebuild,v 1.1 2011/03/04 14:59:14 jlec Exp $
+
+inherit eutils
+
+MY_P="gc-${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
+HOMEPAGE="http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
+SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nocxx threads"
+
+DEPEND="dev-libs/libatomic_ops"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ sed '/Cflags/s:$:/gc:g' -i bdw-gc.pc.in || die
+ local myconf="--with-libatomic-ops=yes"
+
+ if use nocxx ; then
+ myconf="${myconf} --disable-cplusplus"
+ else
+ myconf="${myconf} --enable-cplusplus"
+ fi
+
+ use threads || myconf="${myconf} --disable-threads"
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ rm -rf "${D}"/usr/share/gc || die
+
+ # dist_noinst_HEADERS
+ insinto /usr/include/gc
+ doins include/{cord.h,ec.h,javaxfc.h}
+ insinto /usr/include/gc/private
+ doins include/private/*.h
+
+ dodoc README.QUICK doc/README* doc/barrett_diagram
+ dohtml doc/*.html
+ newman doc/gc.man GC_malloc.1
+}