summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/boo/boo-0.9.0.3203.ebuild')
-rw-r--r--dev-lang/boo/boo-0.9.0.3203.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/dev-lang/boo/boo-0.9.0.3203.ebuild b/dev-lang/boo/boo-0.9.0.3203.ebuild
index 15717c70ea90..ae50d2b7c283 100644
--- a/dev-lang/boo/boo-0.9.0.3203.ebuild
+++ b/dev-lang/boo/boo-0.9.0.3203.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.9.0.3203.ebuild,v 1.1 2009/05/03 21:13:51 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.9.0.3203.ebuild,v 1.2 2009/05/06 08:09:51 loki_val Exp $
EAPI=2
@@ -9,7 +9,6 @@ inherit multilib mono fdo-mime eutils
DESCRIPTION="A wrist friendly language for the CLI"
HOMEPAGE="http://boo.codehaus.org/"
SRC_URI="http://dist.codehaus.org/boo/distributions/${P}-2-src.zip"
-
LICENSE="BSD"
SLOT="0"
@@ -19,7 +18,6 @@ IUSE=""
RDEPEND=">=dev-lang/mono-2.0
x11-libs/gtksourceview:1.0"
DEPEND="${RDEPEND}
- !!<${CATEGORY}/${P}
x11-misc/shared-mime-info
app-arch/unzip
>=dev-dotnet/nant-0.86_beta1"
@@ -28,6 +26,18 @@ MAKEOPTS="${MAKEOPTS} -j1"
RESTRICT="test"
+# Irritating bug: Boo has to be uninstalled for boo to compile.
+pkg_setup() {
+ if has_version ${CATEGORY}/${PN}
+ then
+ eerror "${CATEGORY}/${PN}'s install process is buggy. It requires that you remove any"
+ eerror "existing install before attempting to reinstall it."
+ eerror "Please emerge -C ${CATEGORY}/${PN} and try again."
+ eerror "See http://bugs.gentoo.org/268610 for details."
+ die "Please emerge -C ${CATEGORY}/${PN}"
+ fi
+}
+
src_prepare() {
sed -i -e 's: Boo.Microsoft.Build.Tasks, update-vs2005-env,::' default.build || die
sed -i -e 's@${libdir}/boo@${libdir}/mono/boo@g' \