summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/xjavac/xjavac-20041208-r3.ebuild')
-rw-r--r--dev-java/xjavac/xjavac-20041208-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-java/xjavac/xjavac-20041208-r3.ebuild b/dev-java/xjavac/xjavac-20041208-r3.ebuild
new file mode 100644
index 000000000000..13054da51ddb
--- /dev/null
+++ b/dev-java/xjavac/xjavac-20041208-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/xjavac-20041208-r3.ebuild,v 1.1 2006/08/05 20:15:51 nelchael Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="The implementation of the javac compiler for IBM JDK 1.4 (needed for xerces-2)"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://cvs.apache.org/viewcvs.cgi/xml-xerces/java/tools/src/XJavac.java"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.4"
+RDEPEND=">=virtual/jdk-1.4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ cp ${FILESDIR}/${P}-build.xml ./build.xml || die
+ epatch "${FILESDIR}/${PN}-ibm-1_5.patch"
+}
+
+src_compile() {
+ eant jar -Dclasspath=$(java-pkg_getjars ant-core)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ dodir /usr/share/ant-core/lib/
+ dosym /usr/share/${PN}-${SLOT}/lib/${PN}.jar /usr/share/ant-core/lib/
+}