summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/sptk/sptk-2.2.ebuild')
-rw-r--r--dev-cpp/sptk/sptk-2.2.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-cpp/sptk/sptk-2.2.ebuild b/dev-cpp/sptk/sptk-2.2.ebuild
deleted file mode 100644
index 38b386c56818..000000000000
--- a/dev-cpp/sptk/sptk-2.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-2.2.ebuild,v 1.3 2005/01/01 17:30:03 eradicator Exp $
-
-IUSE="fltk odbc"
-
-DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
-SRC_URI="http://sptk.tts-sf.com/sptk-${PV}.tgz"
-HOMEPAGE="http://sptk.tts-sf.com"
-
-SLOT="2"
-LICENSE="|| ( FLTK GPL-2 )"
-KEYWORDS="-* ~x86 ~sparc ~mips"
-
-DEPEND="fltk? ( x11-libs/fltk )
- odbc? ( >=dev-db/unixODBC-2.2.8 )"
-
-src_compile() {
-
- local myconf
- myconf="--enable-shared"
-
- use odbc || myconf="${myconf} --disable-odbc" #default enabled
- use fltk || myconf="${myconf} --disable-fltk"
-
- econf \
- --prefix=/usr \
- ${myconf} || die "Configuration Failed"
-
- emake || die "Parallel Make Failed"
-}
-
-src_install () {
-
- einstall \
- includedir=${D}/usr/include/sptk \
- libdir=${D}/usr/lib || die "Installation Failed"
-
- dodoc CHANGES COPYING README
-
- dodir /usr/share/doc/${PF}/html
- mv ${D}/usr/share/doc/sptk/* ${D}/usr/share/doc/${PF}/html
- rmdir ${D}/usr/share/doc/sptk
-}