summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-to-cvs.patch')
-rw-r--r--dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-to-cvs.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-to-cvs.patch b/dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-to-cvs.patch
new file mode 100644
index 000000000000..01ed843eb709
--- /dev/null
+++ b/dev-cpp/libgnomecanvasmm/files/2.0.1-gcc3.4-to-cvs.patch
@@ -0,0 +1,42 @@
+--- libgnomecanvas/src/line.hg 2004/07/09 08:38:56 1.1
++++ libgnomecanvas/src/line.hg 2004/07/09 08:40:31
+@@ -115,7 +115,7 @@ namespace Glib
+ {
+
+ template <>
+-class Glib::Value<Gnome::Canvas::Points> : public Glib::Value_Boxed<Gnome::Canvas::Points>
++class Value<Gnome::Canvas::Points> : public Value_Boxed<Gnome::Canvas::Points>
+ {
+ public:
+ static GType value_type() G_GNUC_CONST;
+--- libgnomecanvas/libgnomecanvasmm/line.h 2004/07/09 08:42:09 1.1
++++ libgnomecanvas/libgnomecanvasmm/line.h 2004/07/09 08:42:34
+@@ -286,7 +286,7 @@ namespace Glib
+ {
+
+ template <>
+-class Glib::Value<Gnome::Canvas::Points> : public Glib::Value_Boxed<Gnome::Canvas::Points>
++class Value<Gnome::Canvas::Points> : public Value_Boxed<Gnome::Canvas::Points>
+ {
+ public:
+ static GType value_type() G_GNUC_CONST;
+--- ChangeLog 11 Jul 2004 18:10:49 -0000
++++ ChangeLog 2 May 2004 10:06:31 -0000 1.55.2.2
+@@ -1,3 +1,17 @@
++2004-05-01 Takashi Takekawa <takekawa@users.sourceforge.jp>
++
++ * libgnomecanvas/libgnomecanvas.[h,cc] (GNOMEMM_PROPERTY,
++ GNOMEMM_PROPERTY_IMPL): fixed doubled '>' when T is a template class,
++ for the Intel compiler.
++ * libgnomecanvas/src/line.hg: deleted unnecessary namespace
++ qualification, for the Intel compiler.
++
++2003-12-21 Eric Bourque <ericb@computer.org>
++ * libgnomecanvasmm.spec.in: fixed dependency to gtkmm2 instead of gtkmm
++
++2003-09-25 Eric Bourque <ericb@computer.org>
++ * libgnomecanvasmm.spec.in: updated for libgnomecanvasmm-2.0
++
+ 2.0.1:
+
+ 2003-08-22 Murray Cumming <murrayc@usa.net>