summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/glibmm/glibmm-2.28.2.ebuild')
-rw-r--r--dev-cpp/glibmm/glibmm-2.28.2.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/dev-cpp/glibmm/glibmm-2.28.2.ebuild b/dev-cpp/glibmm/glibmm-2.28.2.ebuild
deleted file mode 100644
index 9b63ad159d01..000000000000
--- a/dev-cpp/glibmm/glibmm-2.28.2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/glibmm-2.28.2.ebuild,v 1.9 2012/05/04 03:44:57 jdhore Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME_TARBALL_SUFFIX="xz"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2
-
-DESCRIPTION="C++ interface for glib2"
-HOMEPAGE="http://www.gtkmm.org"
-
-LICENSE="|| ( LGPL-2.1 GPL-2 )"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="doc debug examples test"
-
-RDEPEND=">=dev-libs/libsigc++-2.2:2
- >=dev-libs/glib-2.28:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README"
- G2CONF="${G2CONF}
- $(use_enable debug debug-refcounting)
- $(use_enable doc documentation)
- --disable-schemas-compile
- --enable-deprecated-api"
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- if ! use test; then
- # don't waste time building tests
- sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
- -i Makefile.am Makefile.in || die "sed 1 failed"
- fi
-
- if ! use examples; then
- # don't waste time building examples
- sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
- -i Makefile.am Makefile.in || die "sed 2 failed"
- fi
-}
-
-src_test() {
- cd "${S}/tests/"
- emake check
-
- for i in */test; do
- ${i} || die "Running tests failed at ${i}"
- done
-}
-
-src_install() {
- gnome2_src_install
-
- if ! use doc && ! use examples; then
- rm -fr "${ED}usr/share/doc/glibmm*"
- fi
-
- if use examples; then
- find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
- dodoc -r examples
- fi
-}