summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild')
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild
index 1de9387b77ca..88751c4b079a 100644
--- a/dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild
+++ b/dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild,v 1.2 2005/09/20 18:30:29 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.3.1.ebuild,v 1.3 2006/04/09 04:20:37 halcy0n Exp $
DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
SRC_URI="mirror://sourceforge/cplusplus/${P}.tar.gz"
@@ -9,16 +9,12 @@ HOMEPAGE="http://www.gnu.org/software/commoncpp/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64"
-IUSE="doc xml2"
+IUSE="doc xml"
-DEPEND="xml2? ( >=dev-libs/libxml2-2.6.19 )"
+DEPEND="xml? ( >=dev-libs/libxml2-2.6.19 )"
src_compile() {
- use xml2 \
- && myconf="${myconf} --with-xml" \
- || myconf="${myconf} --without-xml"
-
- econf ${myconf} || die "./configure failed"
+ econf $(use_with xml) || die "./configure failed"
emake || die
}