summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/mecab/mecab-0.95.ebuild')
-rw-r--r--app-text/mecab/mecab-0.95.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/mecab/mecab-0.95.ebuild b/app-text/mecab/mecab-0.95.ebuild
new file mode 100644
index 000000000000..c4e444fa6851
--- /dev/null
+++ b/app-text/mecab/mecab-0.95.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.95.ebuild,v 1.1 2007/03/12 14:34:28 hattya Exp $
+
+IUSE="unicode"
+
+DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
+HOMEPAGE="http://mecab.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+DEPEND="dev-lang/perl"
+PDEPEND=">=app-dicts/mecab-ipadic-2.7.0.20060707"
+
+src_compile() {
+
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README || die
+ dohtml -r doc || die
+
+}