summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/iso-codes/iso-codes-3.2.ebuild')
-rw-r--r--app-text/iso-codes/iso-codes-3.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/iso-codes/iso-codes-3.2.ebuild b/app-text/iso-codes/iso-codes-3.2.ebuild
new file mode 100644
index 000000000000..f768e506a091
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.2.ebuild,v 1.1 2008/08/03 21:29:24 eva Exp $
+
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
+
+DESCRIPTION="Provides the list of country and language names"
+HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
+SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/gettext
+ >=dev-lang/python-2.3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix install location for multilib machines
+ sed -i -e 's:(datadir)/pkgconfig:(libdir)/pkgconfig:g' Makefile.am
+
+ eautomake
+}
+
+src_compile() {
+ econf || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ChangeLog README TODO
+}