summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/fish')
-rw-r--r--app-shells/fish/ChangeLog10
-rw-r--r--app-shells/fish/files/digest-fish-1.21.13
-rw-r--r--app-shells/fish/fish-1.21.1.ebuild38
3 files changed, 50 insertions, 1 deletions
diff --git a/app-shells/fish/ChangeLog b/app-shells/fish/ChangeLog
index 34dd317e4c9d..8128ea094e58 100644
--- a/app-shells/fish/ChangeLog
+++ b/app-shells/fish/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-shells/fish
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.13 2006/02/16 09:18:18 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.14 2006/03/01 09:46:01 spyderous Exp $
+
+*fish-1.21.1 (01 Mar 2006)
+
+ 01 Mar 2006; Donnie Berkholz <spyderous@gentoo.org>; +fish-1.21.1.ebuild:
+ Bump. Adds command completion for svn and darcs and 'a subsystem for
+ dynamically loading shell script functions at startup, which should make
+ developing and deploying shell scripts easier while reducing startup time
+ and memory usage.'
*fish-1.20.2 (16 Feb 2006)
diff --git a/app-shells/fish/files/digest-fish-1.21.1 b/app-shells/fish/files/digest-fish-1.21.1
new file mode 100644
index 000000000000..f896a46c93b9
--- /dev/null
+++ b/app-shells/fish/files/digest-fish-1.21.1
@@ -0,0 +1,3 @@
+MD5 ac3d2326441ec0f3498d5bd1cec27191 fish-1.21.1.tar.bz2 550612
+RMD160 785c976f2975dc8d14a096f8861524142fb50cf9 fish-1.21.1.tar.bz2 550612
+SHA256 6aa45c39af5376b6587f817c34292c36e00b2bd233fca3f8a277edd6142ccd12 fish-1.21.1.tar.bz2 550612
diff --git a/app-shells/fish/fish-1.21.1.ebuild b/app-shells/fish/fish-1.21.1.ebuild
new file mode 100644
index 000000000000..bc685e71e3f5
--- /dev/null
+++ b/app-shells/fish/fish-1.21.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-1.21.1.ebuild,v 1.1 2006/03/01 09:46:01 spyderous Exp $
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://roo.no-ip.org/fish/"
+SRC_URI="http://roo.no-ip.org/fish/files/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND="sys-libs/ncurses
+ sys-devel/bc
+ || ( (
+ x11-libs/libSM
+ x11-libs/libXext
+ )
+ virtual/x11
+ )"
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_compile() {
+ econf docdir=/usr/share/doc/${PF} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "If you want to use fish as your default shell, you need to add it"
+ einfo "to /etc/shells. This is not recommended because fish doesn't install"
+ einfo "to /bin."
+ einfo
+}