summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/fish/fish-1.20.2.ebuild')
-rw-r--r--app-shells/fish/fish-1.20.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-shells/fish/fish-1.20.2.ebuild b/app-shells/fish/fish-1.20.2.ebuild
new file mode 100644
index 000000000000..63d34ade38a6
--- /dev/null
+++ b/app-shells/fish/fish-1.20.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-1.20.2.ebuild,v 1.1 2006/02/16 09:18:18 spyderous Exp $
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://roo.no-ip.org/fish/"
+SRC_URI="http://roo.no-ip.org/fish/files/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND="sys-libs/ncurses
+ sys-devel/bc
+ || ( (
+ x11-libs/libSM
+ x11-libs/libXext
+ )
+ virtual/x11
+ )"
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_compile() {
+ econf docdir=/usr/share/doc/${PF} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "If you want to use fish as your default shell, you need to add it"
+ einfo "to /etc/shells. This is not recommended because fish doesn't install"
+ einfo "to /bin."
+ einfo
+}