summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/texmacs/texmacs-1.0.0.19.ebuild')
-rw-r--r--app-office/texmacs/texmacs-1.0.0.19.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/app-office/texmacs/texmacs-1.0.0.19.ebuild b/app-office/texmacs/texmacs-1.0.0.19.ebuild
index 34097d8e2b5b..05feb8135f96 100644
--- a/app-office/texmacs/texmacs-1.0.0.19.ebuild
+++ b/app-office/texmacs/texmacs-1.0.0.19.ebuild
@@ -2,9 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
-S=${WORKDIR}/TeXmacs-${PV}-src
+MY_P=${P/tex/TeX}-src
+S=${WORKDIR}/${MY_P}
DESCRIPTION="GNU TeXmacs is a free GUI scientific editor, inspired by TeX and GNU Emacs."
-SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-${PV}-src.tar.gz
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
HOMEPAGE="http://www.texmacs.org/"
@@ -14,27 +15,24 @@ KEYWORDS="~x86"
DEPEND=">=app-text/tetex-1.0.7-r7
>=dev-util/guile-1.3.4
- >=x11-base/xfree-4.2.0-r5"
+ sys-apps/supersed
+ virtual/x11"
RDEPEND="${DEPEND}
app-text/ghostscript"
src_compile() {
-
- cd ${S}
- ./configure
- cd src
- mv common.makefile common.makefile.orig
- cat common.makefile.orig | sed -e 's|CXXOPTIMIZE = -O3 -fexpensive-optimizations -fno-exceptions|CXXOPTIMIZE = -O0|g' > common.makefile
-
- cd ${S}
- make || die
+
+ econf
+ ssed -i "s:\(^CXXOPTIMIZE = \).*:\1${CXXFLAGS}:" src/common.makefile
+
+ cd ${S}
+ make || die
}
src_install() {
- cd ${S}
make DESTDIR=${D} install || die
cd ${WORKDIR}