summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/kword/kword-1.6_beta1.ebuild')
-rw-r--r--app-office/kword/kword-1.6_beta1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-office/kword/kword-1.6_beta1.ebuild b/app-office/kword/kword-1.6_beta1.ebuild
deleted file mode 100644
index 2c27b3783136..000000000000
--- a/app-office/kword/kword-1.6_beta1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-1.6_beta1.ebuild,v 1.1 2006/09/15 18:50:49 carlo Exp $
-
-KMNAME=koffice
-MAXKOFFICEVER=${PV}
-inherit kde-meta eutils
-
-DESCRIPTION="KOffice word processor."
-HOMEPAGE="http://www.koffice.org/"
-LICENSE="GPL-2 LGPL-2"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
- $(deprange $PV $MAXKOFFICEVER app-office/kspread)
- >=app-text/wv2-0.1.8
- >=media-gfx/imagemagick-5.5.2
- >=app-text/libwpd-0.8.2"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-KMCOPYLIB="libkformula lib/kformula
- libkofficecore lib/kofficecore
- libkofficeui lib/kofficeui
- libkopainter lib/kopainter
- libkotext lib/kotext
- libkwmf lib/kwmf
- libkowmf lib/kwmf
- libkstore lib/store
- libkspreadcommon kspread"
-
-KMEXTRACTONLY="
- lib/
- kspread/"
-
-KMCOMPILEONLY="filters/liboofilter"
-
-KMEXTRA="filters/kword"
-
-need-kde 3.4
-
-src_unpack() {
- kde-meta_src_unpack unpack
-
- # We need to compile libs first
- echo "SUBDIRS = liboofilter kword" > $S/filters/Makefile.am
-
- for i in $(find ${S}/lib -iname "*\.ui"); do
- ${QTDIR}/bin/uic ${i} > ${i%.ui}.h
- done
-
- kde-meta_src_unpack makefiles
-}