summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/kspread/kspread-2.2.2.ebuild')
-rw-r--r--app-office/kspread/kspread-2.2.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-office/kspread/kspread-2.2.2.ebuild b/app-office/kspread/kspread-2.2.2.ebuild
new file mode 100644
index 000000000000..dfb028768812
--- /dev/null
+++ b/app-office/kspread/kspread-2.2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/kspread-2.2.2.ebuild,v 1.1 2010/09/25 20:33:05 dilfridge Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice spreadsheet application."
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+solver"
+
+DEPEND="
+ dev-cpp/eigen:2
+ solver? ( sci-libs/gsl )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ kchart/
+ interfaces/
+ libs/
+ filters/
+ plugins/
+"
+KMEXTRA="filters/${KMMODULE}/"
+
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_Eigen2=ON
+ $(cmake-utils_use_with solver GSL)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+}