summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mc/mc-4.8.1-r1.ebuild')
-rw-r--r--app-misc/mc/mc-4.8.1-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/app-misc/mc/mc-4.8.1-r1.ebuild b/app-misc/mc/mc-4.8.1-r1.ebuild
index 0ee12670949f..e0500fd73490 100644
--- a/app-misc/mc/mc-4.8.1-r1.ebuild
+++ b/app-misc/mc/mc-4.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.8.1-r1.ebuild,v 1.1 2011/12/16 10:16:30 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.8.1-r1.ebuild,v 1.2 2011/12/16 13:17:35 wired Exp $
EAPI=4
@@ -15,7 +15,7 @@ SRC_URI="http://www.midnight-commander.org/downloads/${MY_P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
-IUSE="+edit gpm mclib +ncurses nls samba slang test X"
+IUSE="+edit gpm mclib +ncurses nls samba slang test X +xdg"
REQUIRED_USE="^^ ( ncurses slang )"
@@ -44,6 +44,9 @@ src_configure() {
use slang && myscreen=slang
[[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"
+ local homedir=".mc"
+ use xdg && homedir="XDG"
+
econf \
--disable-dependency-tracking \
$(use_enable nls) \
@@ -56,7 +59,8 @@ src_configure() {
--with-screen=${myscreen} \
$(use_with edit) \
$(use_enable mclib) \
- $(use_enable test tests)
+ $(use_enable test tests) \
+ --with-homedir=${homedir}
}
src_install() {