summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-m17n/ibus-m17n-1.2.0.20091120.ebuild')
-rw-r--r--app-i18n/ibus-m17n/ibus-m17n-1.2.0.20091120.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-i18n/ibus-m17n/ibus-m17n-1.2.0.20091120.ebuild b/app-i18n/ibus-m17n/ibus-m17n-1.2.0.20091120.ebuild
new file mode 100644
index 000000000000..1342ae3b0112
--- /dev/null
+++ b/app-i18n/ibus-m17n/ibus-m17n-1.2.0.20091120.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ibus-m17n-1.2.0.20091120.ebuild,v 1.1 2009/11/20 23:28:26 matsuu Exp $
+
+DESCRIPTION="The M17N engine IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2
+ dev-libs/m17n-lib
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-db/m17n-db
+ dev-db/m17n-contrib
+ >=sys-devel/gettext-0.16.1"
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+}