summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/pose/pose-3.5-r3.ebuild')
-rw-r--r--app-emulation/pose/pose-3.5-r3.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/app-emulation/pose/pose-3.5-r3.ebuild b/app-emulation/pose/pose-3.5-r3.ebuild
new file mode 100644
index 000000000000..b7210234f06c
--- /dev/null
+++ b/app-emulation/pose/pose-3.5-r3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pose/pose-3.5-r3.ebuild,v 1.1 2004/01/27 08:49:05 george Exp $
+
+S=${WORKDIR}/Emulator_Src_3.5
+HOMEPAGE="http://www.palmos.com/dev/tools/emulator/"
+SRC_URI="http://www.palmos.com/dev/tools/emulator/sources/emulator_src_3.5.tar.gz"
+
+DESCRIPTION="Palm OS Emulator"
+
+DEPEND=">=x11-libs/fltk-1.1.4"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_unpack() {
+ unpack emulator_src_3.5.tar.gz
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/detect-fluid.diff || die "Patching failed"
+ patch -p1 < ${FILESDIR}/separate-builddir.diff || die "Patching failed"
+ patch -p1 < ${FILESDIR}/choose-gl.diff || die "Patching failed"
+ patch -p0 < ${FILESDIR}/init-clipwidget.diff || die "Patching failed"
+ bzcat ${FILESDIR}/gcc-3.3_fix.diff.bz2 | patch -p1 || die "Patching failed"
+
+ cd ${S}/BuildUnix
+ aclocal
+ automake --foreign
+ autoconf
+ sed -i -e "s:-DPLATFORM_UNIX:-DFLTK_1_0_COMPAT -DPLATFORM_UNIX:" configure
+
+ cd ${S}
+ mkdir install-fltk
+ ln -s /usr/include/fltk-1.1 install-fltk/include
+ ln -s /usr/lib/fltk-1.1 install-fltk/lib
+ mkdir static-libs
+ mkdir build-normal
+# mkdir build-profile
+
+ cd ${S}/static-libs
+ ln -sf `g++ -print-file-name=libstdc++.a` libstdc++.a
+}
+
+src_compile() {
+ cd ${S}/build-normal
+# cd ${S}/BuildUnix
+ LDFLAGS=-L${S}/static-libs ../BuildUnix/configure --prefix=/usr \
+ --with-fltk=${S}/install-fltk \
+ --disable-gl || die
+
+ make || die
+
+# cd ${S}/build-profile
+# LDFLAGS=-L${S}/static-libs ../BuildUnix/configure --prefix=/usr \
+# --with-fltk=${S}/install-fltk \
+# --disable-gl --enable-palm-profile || die
+#
+# make || die
+}
+
+src_install() {
+ cd ${S}/build-normal
+ dobin pose
+
+# cd ${S}/build-profile
+# newbin pose pose-profile
+
+ cd ${S}/Docs
+ dodoc *.txt *.rtf
+ dohtml *.html
+ insinto /usr/share/doc/${PF}
+ doins *.pdf
+
+ dodir /usr/share/pose/downloads
+ dodir /usr/share/pose/roms
+
+ cd ${S}/ROMTransfer/Source
+ insinto /usr/share/pose/downloads
+ doins *.prc
+}
+