summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mg/ChangeLog6
-rw-r--r--app-editors/mg/files/mg-20140220-freebsd.patch28
-rw-r--r--app-editors/mg/mg-20131118.ebuild52
-rw-r--r--app-editors/mg/mg-20140220.ebuild65
4 files changed, 5 insertions, 146 deletions
diff --git a/app-editors/mg/ChangeLog b/app-editors/mg/ChangeLog
index 36a176c2cd4b..de8f00e2e01d 100644
--- a/app-editors/mg/ChangeLog
+++ b/app-editors/mg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/mg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/ChangeLog,v 1.71 2014/03/07 13:44:12 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/ChangeLog,v 1.72 2014/03/13 06:28:53 ulm Exp $
+
+ 13 Mar 2014; Ulrich Müller <ulm@gentoo.org> -mg-20131118.ebuild,
+ -mg-20140220.ebuild, -files/mg-20140220-freebsd.patch:
+ Remove intermediate versions.
*mg-20140306 (07 Mar 2014)
diff --git a/app-editors/mg/files/mg-20140220-freebsd.patch b/app-editors/mg/files/mg-20140220-freebsd.patch
deleted file mode 100644
index 70ba4909e5a9..000000000000
--- a/app-editors/mg/files/mg-20140220-freebsd.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- mg-20140220-orig/sysdef.h
-+++ mg-20140220/sysdef.h
-@@ -15,7 +15,7 @@
- # define __USE_GNU
- #endif
-
--#ifdef __APPLE__
-+#if defined(__APPLE__) || defined(__FreeBSD__)
- # define LOGIN_NAME_MAX _POSIX_LOGIN_NAME_MAX
- #endif
-
---- mg-20140220-orig/tags.c
-+++ mg-20140220/tags.c
-@@ -15,9 +15,12 @@
- #include <err.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <stdio.h>
-
--#ifndef LIBBSD_OVERLAY
--#include <util.h>
-+#if defined(LIBBSD_OVERLAY) || defined(__FreeBSD__)
-+# include <libutil.h>
-+#else
-+# include <util.h>
- #endif
-
- #include "def.h"
diff --git a/app-editors/mg/mg-20131118.ebuild b/app-editors/mg/mg-20131118.ebuild
deleted file mode 100644
index f07b84408052..000000000000
--- a/app-editors/mg/mg-20131118.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/mg-20131118.ebuild,v 1.2 2014/02/13 14:24:37 jer Exp $
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
-HOMEPAGE="http://homepage.boetes.org/software/mg/"
-SRC_URI="http://homepage.boetes.org/software/mg/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 hppa ~x86"
-IUSE="livecd"
-
-RDEPEND="sys-libs/ncurses"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-libs/clens"
-
-src_prepare() {
- epatch_user
-
- # remove OpenBSD specific easter egg
- sed -i -e 's/theo\.o//' GNUmakefile || die
- sed -i -e '/theo_init/d' main.c || die
-
- # fix path to tutorial in man page
- sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" \
- CPPFLAGS="-DFKEYS -DREGEX -DXKEYS -I${EPREFIX}/usr/include/clens" \
- CFLAGS="${CFLAGS}" \
- LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses) -lclens"
-}
-
-src_install() {
- einstall
- dodoc README README_PORTING tutorial
- # don't compress the tutorial, otherwise mg cannot open it
- docompress -x /usr/share/doc/${PF}/tutorial
-}
-
-pkg_postinst() {
- if use livecd; then
- [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
- fi
-}
diff --git a/app-editors/mg/mg-20140220.ebuild b/app-editors/mg/mg-20140220.ebuild
deleted file mode 100644
index 15c6847d307f..000000000000
--- a/app-editors/mg/mg-20140220.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/mg-20140220.ebuild,v 1.4 2014/03/03 21:49:00 ulm Exp $
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
-HOMEPAGE="http://homepage.boetes.org/software/mg/"
-SRC_URI="http://homepage.boetes.org/software/mg/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="livecd"
-
-RDEPEND="sys-libs/ncurses
- !elibc_FreeBSD? ( dev-libs/libbsd )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-freebsd.patch"
- epatch_user
-
- # remove OpenBSD specific easter egg
- sed -i -e 's/theo\.o//' GNUmakefile || die
- sed -i -e '/theo_init/d' main.c || die
-
- # fix path to tutorial in man page
- sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
-
- # remove pkg-config call; we pass flags and libs as parameters
- sed -i -e '/pkg-config/d' GNUmakefile || die
-}
-
-src_compile() {
- local pc=$(tc-getPKG_CONFIG) extraflags extralibs
-
- if use elibc_FreeBSD; then
- extralibs="-lutil"
- else
- extraflags=$("${pc}" --cflags libbsd-overlay)
- extralibs=$("${pc}" --libs libbsd-overlay)
- fi
-
- emake CC="$(tc-getCC)" \
- CPPFLAGS="-DFKEYS -DREGEX -DXKEYS -D__dead=__dead2 ${extraflags}" \
- CFLAGS="${CFLAGS}" \
- LIBS="$("${pc}" --libs ncurses) ${extralibs}"
-}
-
-src_install() {
- einstall
- dodoc README tutorial
- # don't compress the tutorial, otherwise mg cannot open it
- docompress -x /usr/share/doc/${PF}/tutorial
-}
-
-pkg_postinst() {
- if use livecd; then
- [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
- fi
-}