summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/nut/ChangeLog6
-rw-r--r--app-misc/nut/files/nut-17.7-makefile.patch69
-rw-r--r--app-misc/nut/nut-17.12.ebuild30
-rw-r--r--app-misc/nut/nut-17.7.ebuild45
4 files changed, 5 insertions, 145 deletions
diff --git a/app-misc/nut/ChangeLog b/app-misc/nut/ChangeLog
index dccbaddd8dce..7f07a7770729 100644
--- a/app-misc/nut/ChangeLog
+++ b/app-misc/nut/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/nut
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.51 2012/11/20 20:45:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.52 2012/11/21 13:23:06 kensington Exp $
+
+ 21 Nov 2012; Michael Palimaka <kensington@gentoo.org>
+ -files/nut-17.7-makefile.patch, -nut-17.12.ebuild, -nut-17.7.ebuild:
+ Remove old.
20 Nov 2012; Agostino Sarubbo <ago@gentoo.org> nut-18.0.ebuild:
Stable for x86, wrt bug #441088
diff --git a/app-misc/nut/files/nut-17.7-makefile.patch b/app-misc/nut/files/nut-17.7-makefile.patch
deleted file mode 100644
index b778d23572db..000000000000
--- a/app-misc/nut/files/nut-17.7-makefile.patch
+++ /dev/null
@@ -1,69 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -8,15 +8,6 @@
- EXECUTABLE := nut
- LIBS := -lm
-
--FLTK_CONFIG := $(shell fltk-config --version 2>/dev/null)
--ifeq ($(FLTK_CONFIG),)
--HAVE_FLTK = 0
--FLTK_NUT =
--else
--HAVE_FLTK = 1
--FLTK_NUT = fltk/Nut
--endif
--
- OS := $(shell uname -s)
- ifeq ($(OS),HP-UX)
- CC = cc
-@@ -25,7 +16,7 @@
- OPT = -O1
- endif
-
--CFLAGS := $(OPT) -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR)
-+CFLAGS += -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR)
- ifeq ($(CC),gcc)
- CFLAGS += $(OPT) -Wall -fno-inline -ansi
- endif
-@@ -38,7 +29,7 @@
- all: nut $(FLTK_NUT)
-
- nut: $(OBJS)
-- $(CC) $(OPT) -o $(EXECUTABLE) $(OBJS) $(LIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $(EXECUTABLE) $(OBJS) $(LIBS)
-
- ifeq ($(HAVE_FLTK),1)
- $(FLTK_NUT):
---- a/fltk/Makefile
-+++ b/fltk/Makefile
-@@ -5,7 +5,7 @@
- NUTDIR := \".nutdb\"
- FOODDIR := \"$(libdir)\"
- EXECUTABLE := Nut
--LIBS := `fltk-config --ldflags`
-+LIBS := $(shell fltk-config --ldflags)
-
- OS := $(shell uname -s)
- ifeq ($(OS),HP-UX)
-@@ -16,11 +16,7 @@
- OPT = -Os
- endif
-
--CFLAGS := -I.. `fltk-config --optim --cflags` $(OPT) -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR)
--
--ifeq ($(CXX),g++)
--CFLAGS := -I.. `fltk-config --optim --cflags` -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR) -Wall -fno-inline -ansi
--endif
-+CFLAGS := -I.. $(shell fltk-config --optim --cflags) $(OPT) -DNUTDIR=$(NUTDIR) -DFOODDIR=$(FOODDIR) -Wall -fno-inline -ansi
-
- CXXFLAGS := $(CFLAGS)
-
-@@ -28,7 +24,7 @@
- OBJS := ../anameal.o ../db.o ../food.o ../meal.o ../options.o ../prtmenu.o ../recmeal.o ../util.o $(patsubst %.cc,%.o,$(SOURCE))
-
- nut: $(OBJS)
-- $(CXX) $(OPT) -o $(EXECUTABLE) $(OBJS) $(LIBS)
-+ $(CXX) $(CFLAGS) $(LDFLAGS) -o $(EXECUTABLE) $(OBJS) $(LIBS)
-
- deps:
- makedepend -Y.. ../anameal.c ../db.c ../food.c ../meal.c ../options.c ../prtmenu.c ../recmeal.c ../util.c *.cc >/dev/null 2>&1
diff --git a/app-misc/nut/nut-17.12.ebuild b/app-misc/nut/nut-17.12.ebuild
deleted file mode 100644
index f4367a8f8610..000000000000
--- a/app-misc/nut/nut-17.12.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-17.12.ebuild,v 1.1 2012/09/05 16:37:54 jer Exp $
-
-EAPI=4
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Record what you eat and analyze your nutrient levels"
-HOMEPAGE="http://nut.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86"
-IUSE=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-17.12-makefile.patch
-}
-
-src_compile() {
- emake CC=$(tc-getCC) OPT="${CFLAGS}" FOODDIR=\\\"/usr/share/nut\\\"
-}
-
-src_install() {
- insinto /usr/share/nut
- doins raw.data/*
- dobin nut
- doman nut.1
-}
diff --git a/app-misc/nut/nut-17.7.ebuild b/app-misc/nut/nut-17.7.ebuild
deleted file mode 100644
index b3f51290ff63..000000000000
--- a/app-misc/nut/nut-17.7.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-17.7.ebuild,v 1.4 2012/06/07 21:30:33 ranger Exp $
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Record what you eat and analyze your nutrient levels"
-HOMEPAGE="http://nut.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ppc x86"
-IUSE="fltk"
-
-RDEPEND="
- fltk? ( x11-libs/fltk:1 )
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-17.7-makefile.patch
-}
-
-src_compile() {
- emake CC=$(tc-getCC) FOODDIR=\\\"/usr/share/nut\\\"
- if use fltk; then
- cd fltk
- emake CXX=$(tc-getCXX) FOODDIR=\\\"/usr/share/nut\\\"
- fi
-}
-
-src_install() {
- insinto /usr/share/nut
- doins raw.data/*
- dobin nut
- doman nut.1
- if use fltk; then
- dobin fltk/Nut
- doicon nut.xpm
- make_desktop_entry Nut nut nut Education
- fi
-}