summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/gejengel/ChangeLog8
-rw-r--r--media-sound/gejengel/files/gejengel-0.1.4-ffmpeg-1.patch36
-rw-r--r--media-sound/gejengel/gejengel-0.1.4-r1.ebuild7
3 files changed, 46 insertions, 5 deletions
diff --git a/media-sound/gejengel/ChangeLog b/media-sound/gejengel/ChangeLog
index 07cd641ad32a..cb14c3aabca6 100644
--- a/media-sound/gejengel/ChangeLog
+++ b/media-sound/gejengel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/gejengel
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gejengel/ChangeLog,v 1.25 2012/11/20 20:07:44 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gejengel/ChangeLog,v 1.26 2013/01/24 13:42:37 aballier Exp $
+
+ 24 Jan 2013; Alexis Ballier <aballier@gentoo.org> gejengel-0.1.4-r1.ebuild,
+ +files/gejengel-0.1.4-ffmpeg-1.patch:
+ Fix build with ffmpeg-1, part of bug #443220
20 Nov 2012; Agostino Sarubbo <ago@gentoo.org> gejengel-0.1.4-r1.ebuild:
Stable for x86, wrt bug #441396
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg-1.patch b/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg-1.patch
new file mode 100644
index 000000000000..10d43d3da1a4
--- /dev/null
+++ b/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg-1.patch
@@ -0,0 +1,36 @@
+Index: gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
+===================================================================
+--- gejengel-0.1.4.orig/src/AudioDecoder/ffmpegdecoder.cpp
++++ gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
+@@ -83,7 +83,7 @@ void FFmpegDecoder::initialise()
+ avcodec_register_all();
+ av_register_all();
+
+- if (av_open_input_file(&m_pFormatContext, m_Filepath.c_str(), NULL, 0, NULL) != 0)
++ if (avformat_open_input(&m_pFormatContext, m_Filepath.c_str(), NULL, NULL) != 0)
+ {
+ throw logic_error("Could not open input file: " + m_Filepath);
+ }
+@@ -307,21 +307,7 @@ AudioFormat FFmpegDecoder::getAudioForma
+ {
+ AudioFormat format;
+
+- switch(m_pAudioCodecContext->sample_fmt)
+- {
+- case SAMPLE_FMT_U8:
+- format.bits = 8;
+- break;
+- case SAMPLE_FMT_S16:
+- format.bits = 16;
+- break;
+- case SAMPLE_FMT_S32:
+- format.bits = 32;
+- break;
+- default:
+- format.bits = 0;
+- }
+-
++ format.bits = av_get_bytes_per_sample(m_pAudioCodecContext->sample_fmt) << 3;
+ format.rate = m_pAudioCodecContext->sample_rate;
+ format.numChannels = m_pAudioCodecContext->channels;
+ format.framesPerPacket = m_pAudioCodecContext->frame_size;
diff --git a/media-sound/gejengel/gejengel-0.1.4-r1.ebuild b/media-sound/gejengel/gejengel-0.1.4-r1.ebuild
index 2c608503a6bc..ec234a88d729 100644
--- a/media-sound/gejengel/gejengel-0.1.4-r1.ebuild
+++ b/media-sound/gejengel/gejengel-0.1.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gejengel/gejengel-0.1.4-r1.ebuild,v 1.3 2012/11/20 20:07:44 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gejengel/gejengel-0.1.4-r1.ebuild,v 1.4 2013/01/24 13:42:37 aballier Exp $
EAPI=4
inherit eutils multilib flag-o-matic
@@ -37,7 +37,8 @@ DOCS=( AUTHORS ChangeLog README TODO )
src_prepare() {
epatch "${FILESDIR}"/${P}-libnotify-0.7.patch \
- "${FILESDIR}"/${P}-ffmpeg.patch
+ "${FILESDIR}"/${P}-ffmpeg.patch \
+ "${FILESDIR}"/${P}-ffmpeg-1.patch
# Remove Vesion and Encoding from the desktop file
sed -i -e "/Version/d" -e "/Encoding/d" \
data/${PN}.desktop.in || die "sed failed"