summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/slowaes/ChangeLog8
-rw-r--r--dev-python/slowaes/slowaes-0.1-r1.ebuild21
-rw-r--r--dev-python/slowaes/slowaes-0.1.ebuild13
3 files changed, 34 insertions, 8 deletions
diff --git a/dev-python/slowaes/ChangeLog b/dev-python/slowaes/ChangeLog
index 2a8f70507d73..576febecf4e4 100644
--- a/dev-python/slowaes/ChangeLog
+++ b/dev-python/slowaes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/slowaes
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/slowaes/ChangeLog,v 1.2 2013/03/17 15:59:06 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/slowaes/ChangeLog,v 1.3 2013/08/18 13:02:34 blueness Exp $
+
+*slowaes-0.1-r1 (18 Aug 2013)
+
+ 18 Aug 2013; Anthony G. Basile <blueness@gentoo.org> +slowaes-0.1-r1.ebuild,
+ slowaes-0.1.ebuild:
+ Migrate to distutils-r1, bug #481498
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/dev-python/slowaes/slowaes-0.1-r1.ebuild b/dev-python/slowaes/slowaes-0.1-r1.ebuild
new file mode 100644
index 000000000000..664e24156dd6
--- /dev/null
+++ b/dev-python/slowaes/slowaes-0.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/slowaes/slowaes-0.1-r1.ebuild,v 1.1 2013/08/18 13:02:34 blueness Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+MY_P=${P}a1
+DESCRIPTION="AES implementation in pure Python"
+HOMEPAGE="http://code.google.com/p/slowaes/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
diff --git a/dev-python/slowaes/slowaes-0.1.ebuild b/dev-python/slowaes/slowaes-0.1.ebuild
index f1959d59271d..1bcb1f89a3e2 100644
--- a/dev-python/slowaes/slowaes-0.1.ebuild
+++ b/dev-python/slowaes/slowaes-0.1.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/slowaes/slowaes-0.1.ebuild,v 1.1 2012/09/16 20:24:22 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/slowaes/slowaes-0.1.ebuild,v 1.2 2013/08/18 13:02:34 blueness Exp $
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+EAPI=5
-inherit distutils
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
MY_P=${P}a1
DESCRIPTION="AES implementation in pure Python"