summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/bioruby/ChangeLog12
-rw-r--r--sci-biology/bioruby/bioruby-1.1.0.ebuild14
-rw-r--r--sci-biology/bioruby/bioruby-1.3.0.ebuild20
-rw-r--r--sci-biology/bioruby/bioruby-1.4.2.ebuild27
-rw-r--r--sci-biology/bioruby/bioruby-1.4.3.0001.ebuild34
-rw-r--r--sci-biology/bioruby/bioruby-9999.ebuild34
6 files changed, 64 insertions, 77 deletions
diff --git a/sci-biology/bioruby/ChangeLog b/sci-biology/bioruby/ChangeLog
index 871ceb00226a..432cf347cb31 100644
--- a/sci-biology/bioruby/ChangeLog
+++ b/sci-biology/bioruby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/bioruby
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/ChangeLog,v 1.14 2011/12/26 05:16:30 weaver Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/ChangeLog,v 1.15 2013/09/14 12:54:12 mrueg Exp $
+
+*bioruby-1.4.3.0001 (14 Sep 2013)
+
+ 14 Sep 2013; Manuel Rüger <mrueg@gentoo.org> +bioruby-1.4.3.0001.ebuild,
+ -bioruby-1.1.0.ebuild, -bioruby-1.3.0.ebuild, -bioruby-1.4.2.ebuild,
+ bioruby-9999.ebuild:
+ NMU: Version bump. Migrate to ruby-ng eclass. Cleanup old. See bug #475310.
*bioruby-1.4.2 (28 Nov 2011)
@@ -63,4 +70,3 @@
20 Jun 2005; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+bioruby-0.6.2.ebuild:
Initial import.
-
diff --git a/sci-biology/bioruby/bioruby-1.1.0.ebuild b/sci-biology/bioruby/bioruby-1.1.0.ebuild
deleted file mode 100644
index e1241457b11d..000000000000
--- a/sci-biology/bioruby/bioruby-1.1.0.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-1.1.0.ebuild,v 1.1 2007/09/16 10:30:38 markusle Exp $
-
-inherit ruby
-
-DESCRIPTION="An integrated environment for bioinformatics using the Ruby language"
-LICENSE="Ruby"
-HOMEPAGE="http://www.bioruby.org/"
-SRC_URI="http://www.${PN}.org/archive/${P}.tar.gz"
-
-SLOT="0"
-IUSE=""
-KEYWORDS="~ppc ~x86"
diff --git a/sci-biology/bioruby/bioruby-1.3.0.ebuild b/sci-biology/bioruby/bioruby-1.3.0.ebuild
deleted file mode 100644
index a20f580a6fd3..000000000000
--- a/sci-biology/bioruby/bioruby-1.3.0.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-1.3.0.ebuild,v 1.1 2009/03/04 18:40:28 weaver Exp $
-
-inherit ruby
-
-DESCRIPTION="An integrated environment for bioinformatics using the Ruby language"
-LICENSE="Ruby"
-HOMEPAGE="http://www.bioruby.org/"
-SRC_URI="http://www.${PN}.org/archive/${P}.tar.gz"
-
-SLOT="0"
-IUSE=""
-KEYWORDS="~ppc ~x86 ~amd64"
-
-USE_RUBY="ruby18"
-
-src_install() {
- ${RUBY} setup.rb install --prefix="${D}"
-}
diff --git a/sci-biology/bioruby/bioruby-1.4.2.ebuild b/sci-biology/bioruby/bioruby-1.4.2.ebuild
deleted file mode 100644
index e1beb845e329..000000000000
--- a/sci-biology/bioruby/bioruby-1.4.2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-1.4.2.ebuild,v 1.1 2011/12/26 05:16:30 weaver Exp $
-
-EAPI=4
-
-inherit ruby
-
-DESCRIPTION="An integrated environment for bioinformatics using the Ruby language"
-LICENSE="Ruby"
-HOMEPAGE="http://www.bioruby.org/"
-SRC_URI="http://www.${PN}.org/archive/${P}.tar.gz"
-
-SLOT="0"
-IUSE=""
-KEYWORDS="~amd64 ~ppc ~x86"
-
-USE_RUBY="ruby18"
-
-src_install() {
- ${RUBY} setup.rb install --prefix="${D}"
-}
-
-src_test() {
- # NB: Some tests fail but don't raise an error.
- ${RUBY} setup.rb test || die
-}
diff --git a/sci-biology/bioruby/bioruby-1.4.3.0001.ebuild b/sci-biology/bioruby/bioruby-1.4.3.0001.ebuild
new file mode 100644
index 000000000000..2e1edb1a60f2
--- /dev/null
+++ b/sci-biology/bioruby/bioruby-1.4.3.0001.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-1.4.3.0001.ebuild,v 1.1 2013/09/14 12:54:12 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An integrated environment for bioinformatics using the Ruby language"
+LICENSE="Ruby"
+HOMEPAGE="http://www.bioruby.org/"
+SRC_URI="http://www.${PN}.org/archive/${P}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} setup.rb setup || die
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die
+}
+
+each_ruby_test() {
+ ${RUBY} -rubygems test/runner.rb || die
+}
diff --git a/sci-biology/bioruby/bioruby-9999.ebuild b/sci-biology/bioruby/bioruby-9999.ebuild
index 779ec4a80a8d..7be0197a2210 100644
--- a/sci-biology/bioruby/bioruby-9999.ebuild
+++ b/sci-biology/bioruby/bioruby-9999.ebuild
@@ -1,31 +1,39 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-9999.ebuild,v 1.2 2011/09/20 22:11:00 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioruby/bioruby-9999.ebuild,v 1.3 2013/09/14 12:54:12 mrueg Exp $
-EAPI="2"
+EAPI=5
+USE_RUBY="ruby18 ruby19"
EGIT_REPO_URI="git://github.com/bioruby/bioruby.git
- https://github.com/bioruby/bioruby.git"
+ https://github.com/bioruby/bioruby.git"
-inherit ruby git-2
+inherit git-2 ruby-fakegem
DESCRIPTION="An integrated environment for bioinformatics using the Ruby language"
LICENSE="Ruby"
HOMEPAGE="http://www.bioruby.org/"
-#SRC_URI="http://www.${PN}.org/archive/${P}.tar.gz"
SRC_URI=""
-
SLOT="0"
IUSE=""
KEYWORDS=""
-USE_RUBY="ruby18"
+all_ruby_unpack() {
+ git-2_src_unpack
+}
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} setup.rb setup || die
+}
-src_install() {
- ${RUBY} setup.rb install --prefix="${D}"
+each_ruby_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die
}
-src_test() {
- # NB: Some tests fail but don't raise an error.
- ${RUBY} setup.rb test || die
+each_ruby_test() {
+ ${RUBY} -rubygems test/runner.rb || die
}