summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/rpy/ChangeLog7
-rw-r--r--dev-python/rpy/rpy-1.0.1.ebuild63
-rw-r--r--dev-python/rpy/rpy-1.0.2-r1.ebuild6
-rw-r--r--dev-python/rpy/rpy-1.0.2.ebuild55
4 files changed, 9 insertions, 122 deletions
diff --git a/dev-python/rpy/ChangeLog b/dev-python/rpy/ChangeLog
index 850e2ebc5e23..ec49419f4bc2 100644
--- a/dev-python/rpy/ChangeLog
+++ b/dev-python/rpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/rpy
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.22 2008/05/07 08:33:02 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/ChangeLog,v 1.23 2008/06/05 10:19:21 bicatali Exp $
+
+ 05 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org> -rpy-1.0.1.ebuild,
+ -rpy-1.0.2.ebuild, rpy-1.0.2-r1.ebuild:
+ Fixed lapack detection again (bug #224935) and switch texlive and tetex
+ order for doc flag. Cleaned for old versions.
*rpy-1.0.2-r1 (07 May 2008)
diff --git a/dev-python/rpy/rpy-1.0.1.ebuild b/dev-python/rpy/rpy-1.0.1.ebuild
deleted file mode 100644
index d5cb47925d3f..000000000000
--- a/dev-python/rpy/rpy-1.0.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-1.0.1.ebuild,v 1.2 2008/02/26 20:06:19 bicatali Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="Python interface to the R Programming Language"
-HOMEPAGE="http://rpy.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="doc examples lapack"
-
-RDEPEND=">=dev-lang/R-2.6.1
- lapack? ( virtual/lapack )
- dev-python/numpy"
-DEPEND="${RDEPEND}
- doc? ( || ( virtual/tetex dev-texlive/texlive-texinfo ) )"
-
-pkg_setup() {
- if use lapack && ! built_with_use dev-lang/R lapack; then
- eerror "If you want ${PN} with lapack bindings,"
- eerror "you also need dev-lang/R with lapack"
- die "need dev-lang/R compiled with lapack"
- fi
-}
-
-src_unpack() {
- distutils_src_unpack
- # Fix lapack linking issue, bug 143396
- if use lapack; then
- sed -i \
- -e 's:Rlapack:lapack:g' \
- setup.py || die "sed in setup.py failed"
- fi
- epatch "${FILESDIR}"/${PN}-1.0_rc3-version-detect.patch
- epatch "${FILESDIR}"/${PN}-testfiles.patch
-}
-
-src_test() {
- cd tests
- PYTHONPATH=$(ls -d ../build/lib.*) \
- "${python}" testall.py || die "tests failed"
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-
- if use doc; then
- cd doc
- emake html pdf || die "emake docs failed"
- dohtml rpy_html/* || die
- insinto /usr/share/doc/${PF}
- doins rpy.pdf || die
- fi
-}
diff --git a/dev-python/rpy/rpy-1.0.2-r1.ebuild b/dev-python/rpy/rpy-1.0.2-r1.ebuild
index 989d2176028c..b5473e2616a4 100644
--- a/dev-python/rpy/rpy-1.0.2-r1.ebuild
+++ b/dev-python/rpy/rpy-1.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-1.0.2-r1.ebuild,v 1.1 2008/05/07 08:33:02 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-1.0.2-r1.ebuild,v 1.2 2008/06/05 10:19:21 bicatali Exp $
inherit distutils eutils
@@ -16,7 +16,7 @@ IUSE="doc examples"
RDEPEND=">=dev-lang/R-2.6.1
dev-python/numpy"
DEPEND="${RDEPEND}
- doc? ( || ( virtual/tetex dev-texlive/texlive-texinfo ) )"
+ doc? ( || ( dev-texlive/texlive-texinfo virtual/tetex ) )"
src_unpack() {
distutils_src_unpack
@@ -24,7 +24,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-testfiles.patch
epatch "${FILESDIR}"/${P}-rpymodule-R-2.7.patch
# this module should exist only if R was built with USE=lapack
- if [[ -e /usr/$(get_libdir)/R/modules/lapack.so ]]; then
+ if [[ ! -e /usr/$(get_libdir)/R/lib/libRlapack.so ]]; then
sed -i \
-e 's:Rlapack:lapack:g' \
setup.py || die "sed in setup.py failed"
diff --git a/dev-python/rpy/rpy-1.0.2.ebuild b/dev-python/rpy/rpy-1.0.2.ebuild
deleted file mode 100644
index c67fc0657b1c..000000000000
--- a/dev-python/rpy/rpy-1.0.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rpy/rpy-1.0.2.ebuild,v 1.1 2008/04/11 16:38:39 bicatali Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="Python interface to the R Programming Language"
-HOMEPAGE="http://rpy.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="doc examples"
-
-RDEPEND=">=dev-lang/R-2.6.1
- dev-python/numpy"
-DEPEND="${RDEPEND}
- doc? ( || ( virtual/tetex dev-texlive/texlive-texinfo ) )"
-
-src_unpack() {
- distutils_src_unpack
- epatch "${FILESDIR}"/${PN}-1.0_rc3-version-detect.patch
- epatch "${FILESDIR}"/${PN}-testfiles.patch
-
- # this module should exist only if R was built with USE=lapack
- if [[ -e /usr/$(get_libdir)/R/modules/lapack.so ]]; then
- sed -i \
- -e 's:Rlapack:lapack:g' \
- setup.py || die "sed in setup.py failed"
- fi
-}
-
-src_test() {
- cd tests
- PYTHONPATH=$(ls -d ../build/lib.*) \
- "${python}" testall.py || die "tests failed"
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-
- if use doc; then
- cd doc
- emake html pdf || die "emake docs failed"
- dohtml rpy_html/* || die
- insinto /usr/share/doc/${PF}
- doins rpy.pdf || die
- fi
-}