summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-leechcraft/lc-monocle/ChangeLog7
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-0.5.97.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-leechcraft/lc-monocle/ChangeLog b/app-leechcraft/lc-monocle/ChangeLog
index 08866ebd6332..fb9044ab4657 100644
--- a/app-leechcraft/lc-monocle/ChangeLog
+++ b/app-leechcraft/lc-monocle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-monocle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.4 2013/05/26 19:52:16 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.5 2013/06/11 17:32:13 maksbotan Exp $
+
+*lc-monocle-0.5.97 (11 Jun 2013)
+
+ 11 Jun 2013; Maxim Koltsov <maksbotan@gentoo.org> +lc-monocle-0.5.97.ebuild:
+ Bump LeechCraft suite to 0.5.97, thanks to 0xd34df00d.
*lc-monocle-0.5.96 (26 May 2013)
diff --git a/app-leechcraft/lc-monocle/lc-monocle-0.5.97.ebuild b/app-leechcraft/lc-monocle/lc-monocle-0.5.97.ebuild
new file mode 100644
index 000000000000..d9974cd9d860
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-0.5.97.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-0.5.97.ebuild,v 1.1 2013/06/11 17:32:13 maksbotan Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +djvu doc +fb2 +pdf +spectre"
+
+RDEPEND="~app-leechcraft/lc-core-${PV}
+ pdf? ( app-text/poppler[qt4] )
+ djvu? ( app-text/djvu )
+ spectre? ( app-text/libspectre )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable pdf MONOCLE_PDF)
+ $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}