summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/nmap/ChangeLog6
-rw-r--r--net-analyzer/nmap/files/nmap-6.25-liblua-ar.patch20
-rw-r--r--net-analyzer/nmap/nmap-6.25.ebuild16
3 files changed, 34 insertions, 8 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 226470721f02..c8bf312fb9c7 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nmap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.280 2013/01/16 19:21:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.281 2013/01/16 19:33:08 jer Exp $
+
+ 16 Jan 2013; Jeroen Roovers <jer@gentoo.org> nmap-6.25.ebuild,
+ +files/nmap-6.25-liblua-ar.patch:
+ Fix AR/RANLIB again (bug #445524).
16 Jan 2013; Jeroen Roovers <jer@gentoo.org> nmap-6.01.ebuild:
Fix AR/RANLIB again (bug #445524).
diff --git a/net-analyzer/nmap/files/nmap-6.25-liblua-ar.patch b/net-analyzer/nmap/files/nmap-6.25-liblua-ar.patch
new file mode 100644
index 000000000000..5aa9fa7f631c
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-6.25-liblua-ar.patch
@@ -0,0 +1,20 @@
+--- a/liblua/Makefile
++++ b/liblua/Makefile
+@@ -11,7 +11,7 @@
+ LDFLAGS= $(SYSLDFLAGS) $(MYLDFLAGS)
+ LIBS= -lm $(SYSLIBS) $(MYLIBS)
+
+-AR= ar rcu
++AR= ar
+ RANLIB= ranlib
+ RM= rm -f
+
+@@ -56,7 +56,7 @@
+ a: $(ALL_A)
+
+ $(LUA_A): $(BASE_O)
+- $(AR) $@ $(BASE_O)
++ $(AR) rcu $@ $(BASE_O)
+ $(RANLIB) $@
+
+ $(LUA_T): $(LUA_O) $(LUA_A)
diff --git a/net-analyzer/nmap/nmap-6.25.ebuild b/net-analyzer/nmap/nmap-6.25.ebuild
index 660847a11035..b86342f67e56 100644
--- a/net-analyzer/nmap/nmap-6.25.ebuild
+++ b/net-analyzer/nmap/nmap-6.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-6.25.ebuild,v 1.9 2013/01/16 09:21:02 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-6.25.ebuild,v 1.10 2013/01/16 19:33:08 jer Exp $
EAPI="4"
PYTHON_DEPEND="2"
@@ -71,7 +71,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-5.10_beta1-string.patch \
"${FILESDIR}"/${PN}-5.21-python.patch \
"${FILESDIR}"/${PN}-6.01-make.patch \
- "${FILESDIR}"/${PN}-6.25-lua.patch
+ "${FILESDIR}"/${PN}-6.25-lua.patch \
+ "${FILESDIR}"/${PN}-6.25-liblua-ar.patch
sed -i \
-e 's/-m 755 -s ncat/-m 755 ncat/' \
ncat/Makefile.in || die
@@ -104,11 +105,6 @@ src_prepare() {
zenmap/install_scripts/unix/zenmap-root.desktop \
zenmap/install_scripts/unix/zenmap.desktop || die
- # respect AR and RANLIB, wrt bug #445524
- tc-export AR RANLIB
- sed -i -e '/^RANLIB/d' -e '/^AR/d' liblinear/{,blas}/Makefile || die
- sed -i -e '/^RANLIB/d' -e "/^AR/s/ar/$(tc-getAR)/" liblua/Makefile || die
- sed -i -e '/^AR/d' {libnetutil,libpcre,nbase,nsock/src}/Makefile.in || die
}
src_configure() {
@@ -126,6 +122,12 @@ src_configure() {
--with-libdnet=included
}
+src_compile() {
+ emake \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB )
+}
+
src_install() {
LC_ALL=C emake -j1 \
DESTDIR="${D}" \