summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/icu/ChangeLog6
-rw-r--r--dev-libs/icu/files/icu-4.6.1-parallel_installation.patch32
-rw-r--r--dev-libs/icu/icu-4.6.1.ebuild6
3 files changed, 41 insertions, 3 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index f656a7308cfd..cfaf60b01a7f 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.145 2011/04/26 20:17:01 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.146 2011/04/27 18:49:31 arfrever Exp $
+
+ 27 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ icu-4.6.1.ebuild, +files/icu-4.6.1-parallel_installation.patch:
+ Fix parallel installation (bug #272328).
26 Apr 2011; Christoph Mende <angelos@gentoo.org> icu-4.6.1.ebuild:
Stable on amd64 wrt bug #364409
diff --git a/dev-libs/icu/files/icu-4.6.1-parallel_installation.patch b/dev-libs/icu/files/icu-4.6.1-parallel_installation.patch
new file mode 100644
index 000000000000..e4eec2d4a72b
--- /dev/null
+++ b/dev-libs/icu/files/icu-4.6.1-parallel_installation.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/show_bug.cgi?id=272328
+https://ssl.icu-project.org/trac/ticket/7628
+https://ssl.icu-project.org/trac/changeset/29657
+
+--- extra/uconv/Makefile.in
++++ extra/uconv/Makefile.in
+@@ -1,6 +1,6 @@
+ ## ******************************************************************************
+ ## *
+-## * Copyright (C) 1999-2009, International Business Machines
++## * Copyright (C) 1999-2011, International Business Machines
+ ## * Corporation and others. All Rights Reserved.
+ ## *
+ ## *******************************************************************************
+@@ -147,7 +147,7 @@
+ endif
+
+
+-package-resfiles: $(RESDIR)/$(RESDIR).lst pkgdata.inc
++package-resfiles: $(RESFILES) $(RESDIR)/$(RESDIR).lst pkgdata.inc
+ $(INVOKE) $(PKGDATA_INVOKE_OPTS) $(TOOLBINDIR)/pkgdata -p $(MSGNAME) $(PKGDATA_OPTS) -m $(PKGMODE) -s $(RESDIR) -d $(RESDIR) -T $(RESDIR) $(RESDIR)/$(RESDIR).lst
+
+ $(RESDIR)/$(RESDIR).lst: Makefile $(srcdir)/resfiles.mk
+@@ -159,7 +159,7 @@
+
+ # no install for static mode
+ ifneq ($(UCONVMSG_MODE),static)
+-install-resfiles: $(RESFILES)
++install-resfiles: $(RESFILES) $(RESDIR)/$(RESDIR).lst pkgdata.inc
+ $(MKINSTALLDIRS) $(DESTDIR)$(ICUDATA_DIR)
+ $(INVOKE) $(TOOLBINDIR)/pkgdata -p $(RESDIR) -O pkgdata.inc -m $(PKGMODE) -d $(RESDIR) -I $(INSTALLTO) -T $(RESDIR) $(RESDIR)/$(RESDIR).lst
+ else
diff --git a/dev-libs/icu/icu-4.6.1.ebuild b/dev-libs/icu/icu-4.6.1.ebuild
index 974db0ebca9c..d97c2c82630e 100644
--- a/dev-libs/icu/icu-4.6.1.ebuild
+++ b/dev-libs/icu/icu-4.6.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.6.1.ebuild,v 1.3 2011/04/26 20:17:01 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.6.1.ebuild,v 1.4 2011/04/27 18:49:31 arfrever Exp $
EAPI="3"
-inherit versionator
+inherit eutils versionator
MAJOR_MINOR_VERSION="$(get_version_component_range 1-2)"
MICRO_VERSION="$(get_version_component_range 3)"
@@ -49,6 +49,8 @@ src_prepare() {
for variable in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
sed -i -e "/^${variable} =.*/s:@${variable}@::" config/Makefile.inc.in || die "sed failed"
done
+
+ epatch "${FILESDIR}/${P}-parallel_installation.patch"
}
src_configure() {