summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/pytextile/ChangeLog9
-rw-r--r--app-text/pytextile/pytextile-2.2.2.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/app-text/pytextile/ChangeLog b/app-text/pytextile/ChangeLog
index 598c1d175d8f..859a01e7cc02 100644
--- a/app-text/pytextile/ChangeLog
+++ b/app-text/pytextile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pytextile
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/ChangeLog,v 1.42 2014/12/10 22:38:32 xarthisius Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/ChangeLog,v 1.43 2015/02/16 04:39:56 idella4 Exp $
+
+*pytextile-2.2.2 (16 Feb 2015)
+
+ 16 Feb 2015; Ian Delaney <idella4@gentoo.org> +pytextile-2.2.2.ebuild:
+ bump
10 Dec 2014; Kacper Kowalik <xarthisius@gentoo.org> -pytextile-2.1.5.ebuild:
Drop old, fixes #453980
diff --git a/app-text/pytextile/pytextile-2.2.2.ebuild b/app-text/pytextile/pytextile-2.2.2.ebuild
new file mode 100644
index 000000000000..a635e7a40c9a
--- /dev/null
+++ b/app-text/pytextile/pytextile-2.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/pytextile-2.2.2.ebuild,v 1.1 2015/02/16 04:39:56 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="textile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python implementation of Textile, Dean Allen's Human Text Generator for creating (X)HTML"
+HOMEPAGE="http://github.com/textile/python-textile"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND="
+ dev-python/regex[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # This resolves a nasty race condition, courtesy of Arfrever
+ sed -e 's:with-id = 1::' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests textile/tests/ || die "Tests failed under ${EPYTHON}"
+}